Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to fix “The system is running in low-graphics mode” error?

So I just bought a new laptop and am attempting to put Ubuntu 10.4 on it's own partition. After installation, I found that I was unable to change my screen resolution and that it labeled my monitor type as "unknown". I figured the issue was that I did not have the nvidia drivers installed so I downloaded and installed them from nvidia's website.

This process involved killing the xserver while install went through, which wasn't too much trouble. After installing the drivers, upon a fresh reboot I am given an error message stating that Ubuntu is running in low-graphics mode. I am given the typical 5 options to choose from, but niether gets my screen resolution working properly.

I have an nvidia 550M on a new Asus laptop. Asus N53SN http://www.asus.com/Notebooks/Multimedia_Entertainment/N53SN/#specifications

Brand new, fresh install of Ubuntu 10.4.

What my corg.conf file looks like:

Section "ServerLayout"
Identifier "Layout0"
Screen  0  "Screen0" 0 0
InputDevice  "Keyboard0" "CoreKeyboard"
InputDevice  "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier   "Mouse0"
Driver     "mouse"
Option    "Protocol" "auto"
Option    "Device" "/dev/psaux"
Option    "Emulate3Buttons" "no"
Option     "ZAxisMapping"  "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier   "Keyboard0"
Driver    "kbd"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Unknowkn"
ModelName    "Unknown"
HorizSync   28.0-33.0
VertRefresh   43.0-72.0
Option    "DPMS"
EndSection

Section "Device"
Identifier   "Device0"
Driver    "nvidia"
VendorName  "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier   "Screen0"
Device   "Device0"
Monitor    "Monitor0"
DefaultDepth    24
SubSection    "Display"
    Depth    24
EndSubsection
EndSection
share|improve this question

marked as duplicate by jokerdino, Stephen Myall, con-f-use, hexafraction, Mik Oct 26 '12 at 14:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Have you blacklisted the open source nouveau driver? Check what modules are loaded with lsmod. –  mikewhatever Mar 17 '12 at 22:50
    
How do I blacklist it? I have it listed in lsmod as "nouveau 515227 (size) 0 –  Simba Mar 17 '12 at 23:55
    
I believe I have blacklisted nouveau and I am still getting the problem. I even completely removed nouveau from my system and I still have the same issue. –  Simba Mar 18 '12 at 2:19
add comment

1 Answer 1

Run gksudo gedit /etc/modprobe.d/blacklist.conf, and add the following to the bottom:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

...save and reboot.

PS: If you want the monitor to become known, edit the "Monitor" section of xorg.cong, for example:

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Aliens"
ModelName    "XoXo"
HorizSync   28.0-33.0
VertRefresh   43.0-72.0
Option    "DPMS"
EndSection
share|improve this answer
    
This does not change anything really. I have noticed another little thing when I boot ubuntu in low-graphics mode. When I try to access my monitor display settings it asks if I want to run NVIDIA X server settings and when I do, I get an error stating "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server. –  Simba Mar 18 '12 at 3:00
    
When I do the above and reboot, I still have the low graphics problem and the above error message popup when I try to access my monitor display settings. I have tried using this website as a reference to solve my issues aswell, and to no avail: blog.musicvm.com/… –  Simba Mar 18 '12 at 3:02
    
Hm..., try re-installing the Nvidia driver again, also, check if nouveau got blacklisted with lsmod. –  mikewhatever Mar 18 '12 at 4:08
    
ive reinstalled the drivers already twice i believe. also an lsmod shows nothing relating to nouveau now... so that's good i guess. –  Simba Mar 18 '12 at 4:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.