Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran the command:

ifconfig -a

which gave this output, there is no eth0:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:82330 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82330 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11151678 (11.1 MB)  TX bytes:11151678 (11.1 MB)

usb0      Link encap:Ethernet  HWaddr 6a:55:7c:ee:9a:59  
          inet addr:192.168.42.230  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::6855:7cff:feee:9a59/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2893 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9773 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:923185 (923.1 KB)  TX bytes:1483133 (1.4 MB)

wlan0     Link encap:Ethernet  HWaddr 8c:a9:82:21:ee:02  
          inet6 addr: fe80::8ea9:82ff:fe21:ee02/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:14250 errors:0 dropped:0 overruns:0 frame:0
          TX packets:92483 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6283319 (6.2 MB)  TX bytes:54238522 (54.2 MB)

And I ran cat /etc/network/interfaces:

auto lo
iface lo inet loopback

I ran lspci -nn |grep Ethernet:

04:00.0 Ethernet controller [0200]: Atheros Communications AR8152 v1.1 Fast Ethernet [1969:2060] (rev c1)

How would I install ethernet drivers?

share|improve this question
1  
What does this show? lspci -nn |grep Ethernet –  LnxSlck Mar 17 '12 at 18:07
    
Obviously, there's no universal answer to your question. Typical sequence is to look thru the devices list as LnxSlck pointed out, then to find the unclaimed ethernet device, discover it's PCI Vendor IDs and google them. –  mbaitoff Mar 17 '12 at 18:13
    
04:00.0 Ethernet controller [0200]: Atheros Communications AR8152 v1.1 Fast Ethernet [1969:2060] (rev c1) –  Srinivas Reddy Thatiparthy Mar 17 '12 at 18:15
    
Which Ubuntu version are you using, which kernel are you using.. –  Uri Herrera Mar 17 '12 at 18:30
    
ubuntu 10.04 and uname -a gave me this , Linux srinivas-laptop 2.6.32-38-generic #83-Ubuntu SMP Wed Jan 4 11:12:07 UTC 2012 x86_64 GNU/Linux. –  Srinivas Reddy Thatiparthy Mar 17 '12 at 18:37

3 Answers 3

up vote 1 down vote accepted

I found the solution for this problem,

just run these following commands

sudo apt-get update

sudo apt-get install linux-backports-modules-wireless-lucid-generic
share|improve this answer

I found some info on that issue, it seems like Ubuntu isn't able to find the drivers for your network card, try these steps:

Go to http://linuxwireless.org download the latest compat-wireless driver and follow the instructions.

Even though it is called “wireless” it works like a charm. After the download is completed open the terminal (Ctrl+Alt+T) and navigate to the directory where the downloaded file is saved (cd ~/Downloads/)[in my case the file is stored in the downloads folder]

Write the following commands:

$ tar -xjvf compat-wireless-2.6.tar.bz2
$ cd compat-wireless* #Do not write the asterisk (*) when you reach the asterisk press the Tab key and press enter]
$ scripts/driver-select atl1c
$ make
$ sudo make install
$ sudo reboot
$ sudo modprobe atl1c #This command is written after the computer is rebooted

Information http://codingexplorer.wordpress.com/2010/10/04/ubuntu-10-04-does-not-recognize-ethernet-interface/

http://ubuntuforums.org/showthread.php?t=1505697&page=11

share|improve this answer
    
That kind of installation compromises the package management state. There is a package "compat-wireless-...", install it using the package manager instead. –  mbaitoff Mar 17 '12 at 19:11
    
You should add that comment as an answer! –  fossfreedom Mar 18 '12 at 10:55

I found a blog which this problem's solution

http://arajpraju.blogspot.in/2012/09/fix-for-atheros-ar-8162-for-ubuntu-1204.html

share|improve this answer
    
Technically it might answer the question but the link can be deleted or changed.So better provide the info here –  Stormvirux Mar 6 at 6:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.