Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using dual monitors with my laptop. I used nvidia's configuration tool (nvidia-xconfig) to detect the second monitor (via HDMI) and setup twinview, no problems. Now, if I try to boot up without that monitor, I'm having a strange issue.

On boot, everything is normal. Then, I get an error on the left side of the screen saying checks failed for a large variety of screen resolutions and frequencies. In addition, my mouse only moves in a small column on the left side of the screen, and clicks are registered, quite strangely, on the right side of the screen. I can't click on Unity at all. However, the keyboard works, so I can get into the terminal with the Windows key. I tried getting into nvidia-xconfig, but the GUI did not come up. I tried to manually edit /etc/X11/xorg.conf, but I don't know what to change.

Does anyone know of a way I can reset my display settings through the command line or through manually editing xorg.conf? Thanks!

share|improve this question

closed as off topic by fossfreedom Mar 17 '12 at 18:35

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

There's a tweak in xorg.conf for nvidia drivers that forces the detection of an absent monitor as if was plugged in. The exact tweak is described in readme file which is distributed along with the nvidia driver. – mbaitoff Mar 17 '12 at 18:19
The developers for 12.04 are actively looking for testers with multiple monitors. This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. – fossfreedom Mar 17 '12 at 18:35