Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've compiled my file using the following command

gcc -o rget rget.c filerpc_clnt.c filerpc_xdr.c -Insl

I find that the file property "Allow files to be executed as program" is not enabled.

and so when i tried to execute i'm getting the permission denied message

./rget localhost mytestfile.txt
bash: ./rget: Permission denied
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

[Comments answered by OP]

The problem with that executable files is that it was in the windows formatted drive... so i moved that to the home directory and then executed the following command chmode +x rget and now i'm able to execute it. Thanks for all your support

share|improve this answer
add comment

try to do a chmod a+x rget to activate the execution permission. If the file is on NTFS or FAT, you have to change mounting options in fstab

share|improve this answer
    
I tried what you said, but still i face the same issue. –  user824910 Mar 17 '12 at 12:39
1  
The problem with that executable files is that it was in the windows formatted drive... so i moved that to the home directory and then executed the following command chmode +x rget and now i'm able to execute it. Thanks for all your support –  user824910 Mar 17 '12 at 14:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.