Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way to fix the ugly boot when using NVidia and Ubuntu 11.10?

I fixed the issues when I was using 10.10 but 11.10 the same fix just trashes the system.

Thanks

share|improve this question
    
How did you fix it in 10.10? doesn't it work on 11.10 –  Prasad RD Mar 17 '12 at 11:55
    
What did you do.. –  Uri Herrera Mar 17 '12 at 18:32

1 Answer 1

up vote 1 down vote accepted

NVidia drivers PPA, and upgrade:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update && sudo apt-get install nvidia-current nvidia-settings

Configuring The Right Driver

The next thing to do is to make sure that your machine uses the correct driver. To ensure that, we are going to blacklist the nouveau driver first. Open a terminal and enter the following to do so:

sudo nano /etc/modprobe.d/blacklist.conf

At the end of the document, add this line:

[...]

blacklist nouveau

Afterwards update your initial ram file system by entering this into a terminal:

sudo update-initramfs -u -v

Then check:

sudo nano /etc/X11/xorg.conf

Find the Device section and make sure the driver is set to "nvidia". It should look somewhat like this:

[...]

Section "Device"

Driver "nvidia"

Identifier "Default Device"

Option "NoLogo" "True" EndSection

[...]

Second fix

Try this:

  1. We will have to edit grub configuration. Open a terminal and paste this:

sudo gedit /etc/default/grub - Hit Enter. It will open grub preferences in Gedit.

  1. Locate the line "# GRUB_GFXMODE=800x600" (resolution may be different).

U have to change the resolution to actual resolution of your screen, for example mine is 1240x1024. Next step is to uncomment this line (remove the # and and the empty space if is, so the letter G of the word GRUB will be the first letter in this line). After u r done, save the file and close.

  1. Now paste this line in terminal:

sudo gedit /etc/grub.d/00_header .

Hit Enter. It will open a text file with a lot of stuff. Use the search option at the top of the window to locate this line:

gfxmode=${GRUB_GFXMODE} .

After u successfully find it, u will have to add this line: "set gfxpayload=keep" (of course without the " sign) just under the gfxmode=${GRUB_GFXMODE}. Make it look like this:

set gfxmode=${GRUB_GFXMODE} set gfxpayload=keep

Now, save the file and close.

  1. In terminal paste:

sudo update-grub

Hit enter, it will generate new grub.cfg file so the changes u made will be saved.

Reboot and enjoy your new boot screen resolution.

In case u don't know what is your screen resolution

Go to System settings - Displays

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.