Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to start the game,Frozen Throne (using wine) with the option of "-opengl".When I entered the game,the resolution will changed,and restored after exit the game.

But this time a problem happened.The resolution can't restore although I restart my computer several times. Both the Ubuntu pane and login windows are exceptional. nvidia-settingsalso detect the resolution is "1024 x 768",But it seemed useless using this tool. Screenshot-NVIDIA X Server Settings: nvidia-settings

the result of xrandr:

   Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1024 x 768
   default connected 1024x768+0+0 0mm x 0mm


   1024x768       50.0* 
   800x600        51.0     52.0     53.0  
   680x384        54.0     55.0  
   640x480        56.0  
   576x432        57.0  
   512x384        58.0  
   400x300        59.0     60.0     61.0  
   320x240        62.0  

the configure of /etc/X11/xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Fri Apr  9 11:51:21 UTC 2010


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       28.0 - 55.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Entry Graphics"
EndSection

Section "Screen"

# Removed Option "metamodes" "1024x768 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1024x768_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

1 Answer 1

up vote 2 down vote accepted

Your xorg.conf file contains the "metamodes" option. Remove that line, and it should be back to normal if you log out and back in again.

To get the best results (or if that doesn't work), delete your xorg.conf, restart your computer (press ESC before it boots to get the boot menu), enter recovery mode, choose root terminal, and type nvidia-xconfig and press enter. That should reset your xorg.conf file.

Now type reboot and enter to restart your system, and all should be well.

share|improve this answer
    
@Roland Taylor After I comment (or delete)the "metamodes" line,and log out,It seemed nothing changed to my screen.So I delete the configure file "xorg.conf",enter the recovery mode,with root authority, type nvidia-xconfig ,reboot to enter my gnome,all back to the default settings,the resolution changed to "600 x 300"(may be not correct,but much of a size).BTW:I create the backup of xorg.conf. –  kit.yang Nov 4 '10 at 16:49
    
O.O? Are you running the latest driver, an old card? something doesn't add up with that one O.o... I've never had the nvidia driver do that to me O.o. When I get the chance I'll take a look at the commandline options and see what other options you can use. –  RolandiXor Nov 4 '10 at 21:28
    
Thanks,ah,It works well previously.So it may not be the problem of driver or graphics card.Reinstall the ubuntu-desktop is the last choice possibility. –  kit.yang Nov 5 '10 at 4:41
1  
-1: You don't need to reboot to change the resolution, as the nvidia-settings allows you to change them, and apply them. Nvidia will remember the settings for the next login, so there is no reason to overwrite xorg.conf either just because of a changed solution. That's the whole purpose of nvidia-settings. –  user2817 Jan 4 '11 at 4:48
1  
If you have nVidia too, then why didn't you just describe how to change the resolution with nvidia-settings? –  user2817 Jan 4 '11 at 19:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.