Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using dual monitors, and i want to be able to play a movie with sound on the TV (through vlc or something) and then play youtube og some games with my headphones on my laptop. Is there anyway i can choose what hardware each application uses?

I've tried using pavucontrol, but am not given an option to change the output device: screenshot
and it doesn't make any difference if i click the lock icon on the right

EDIT:

jeggy@localhost:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC665 Analog [ALC665 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC665 Digital [ALC665 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Don't know if this helps with anything?

share|improve this question
    
which version of ubuntu are you using? –  fossfreedom Mar 17 '12 at 9:29
    
I'm using ubuntu 11.10 64-bit –  Jeggy Mar 17 '12 at 12:38
    
Can you please try another sound card –  Tachyons May 10 '12 at 14:11
    
How can i use another sound card? do i have to buy new hardware? or some new driver? –  Jeggy May 10 '12 at 14:12
2  
question: could it be that there is nothing here cuz the 'lock' at the left side is active? in the screenshot below the lock seems to be open: it looks 'pressed'. –  Rinzwind May 10 '12 at 14:26
show 4 more comments

5 Answers 5

up vote 4 down vote accepted
+100

I think we are overlooking the simplest answer here, I think you only have one sound card, and correct me if I'm wrong... but don't you need to have more then one sound card to be able to use different output devices.

In your question you wants to play the sound from one program thru the headphone output witch is probable connected to your "only" sound card, and one programs sound thru the speakers connected to the computer, witch once again is probably the "only" sound card you have. And has far as I know you can't play one sound to the headphone output and another sound to another output on the same card.

I don't know witch version of ubuntu you are using but in the picture you have provided there is a tab called "Output Devices" you can check there if you have more then one sound card. I have provided a screen-shot of how my looks, observe that it lists 3 devices but i only have 2 there is two "Bulit-in Audio" and i can not play different sounds to them.

enter image description here

It might be clearer to run "aplay -l" in a terminal

Example:

aplay -l

yealds ...

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC271X Analog [ALC271X Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC271X Digital [ALC271X Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

there it is easier to see that there is two cards card 0 and card 1

So if you only have one soundcard my advice to you would be to buy a USB sound card and connect your headphones to that. and then use duffyducks or andys answer to choose output device

share|improve this answer
    
I believe that this is the most likely case. Kempe beat me to it and posted the same answer I was going to give you. I think you need to post the results of aplay -l here so we can help you out. –  Jim C May 14 '12 at 18:35
    
Alright, thanks :D it says i only have 1 sound card –  Jeggy May 14 '12 at 20:53
add comment

You could try PulseAudio Volume Control (pavucontrol Install pavucontrol).
sudo apt-get install pavucontrol

Then select output device like so.

pavucontrol screenshot

share|improve this answer
    
I installed that but i don't get that option to select which output to pick ? khp.randompoop.net/uploads/… –  Jeggy Mar 16 '12 at 21:16
    
I wish I knew why dude. Maybe post a new question using my screenshot and yours asking, why? –  duffydack Mar 16 '12 at 21:33
add comment

If it works in general it should look for vlc (version 2.0.1) like this as well: vlc 2.0.1

As you can see in the screenshot, you may choose the audio device in vlc itself.

If that's also not possible, your PC might not be able to forward sound to your TV due to hardware limitations. To investigate further on this one would need the type of your sound card or graphics card, of your TV and of the connection between them like HDMI, DisplayPort and so on.

share|improve this answer
    
The Audio Device is grayed out. :( –  Jeggy May 10 '12 at 19:33
    
Works for me! Yay! I can stream music from my kids on the bluetooth, while listening to my own stuff on the default device :) –  Yanick Rochon Jan 24 at 1:29
add comment

Well I cant tell you about UNITY as of now....But if you do not have a problem to switch to Gnome 3.4/3.2 then you directly get an extension on gnomeextensions

LINK- https://extensions.gnome.org/

the extension enables you to control the volume of specific applications directly from the sound menu...!!! :)

share|improve this answer
    
Still not working :( ... but i tried this extension extensions.gnome.org/extension/142/… that one is really nice but not working for audio output :( –  Jeggy May 14 '12 at 17:09
    
Try this one.... I use it and it works... extensions.gnome.org/extension/212/advanced-volume-mixer –  Nirmik May 14 '12 at 17:18
add comment

Try thi one....

I use it and it works...

https://extensions.gnome.org/extension/212/advanced-volume-mixer/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.