Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a bit of an annoying problem with Banshee. I have a library that's not so big, only 300-400 songs. However, I'm the problem arises when I play songs. When I double click to play a song, it plays normally, as expected. But during a playlist or my whole library, or even a playlist with a single song being played, something funny happens: It starts the next track f.ex. in the middle, but not at the beginning. Rarely at the beginning. This is quite annoying, and I don't really have an idea what may cause it. It used to work completely fine before, and I find it hard to believe that it may be a matter of a corrupted database in Banshee.

Has anyone else had this problem, and if so, is there any solution to this?

I'm sorry if this is the wrong place to ask, but I believe it'd be appropriate since I do run Ubuntu (11.10) and Banshee is the default player.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Problem solved:


The problem was caused by the gapless playback option. Disabling it made the problem disappear with instant effect.
There seems to have been a good amount of problems with this feature throughout history when I searched it up.
The reason why it happens is hard to understand off the bat, but it's most probably a bug.

share|improve this answer
    
It'd be nice if you also accepted your own answer so others can see that it's solved. –  Jo-Erlend Schinstad Nov 13 '12 at 10:02

Possible cause:

As hard as it might be to believe, it is most likely a corrupt database.

Possible solution:

You can backup your database, then rescan your library, and the problem should be gone. If it is not gone, then you need to report a bug (because it would be something wrong in the code and not the database.

To backup the database:

  • Navigate to /home/yourusername/.config/banshee-1
  • Rename banshee.db to something else (such as bansheebk.db)

To rescan the library:

  • Open Banshee
  • Go to: Tools>Rescan Music Library

Let it complete, then try playing music again and the problem should be gone.

share|improve this answer
    
It didn't solve the problem... What I just saw was this: The slider actually moves, all by itself, through the seekbar to some random point. I don't have any idea what that's about. It's a clean, newly made database, too. Would this qualify as a bug, or should I make further research before filing it? –  Howy Mar 16 '12 at 23:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.