Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A printer was installed and worked but does not now. A job is successfully submitted, but keeps waiting there for printing (as seen from lpq command).

Ping to printer works fine. (The printer is on and works as it prints from Windows.) But on the Printer Property, it shows Printer State: Idle - /usr/lib/cups/backend/dnssd failed.

The following command does not help either.

sudo service avahi-daemon restart

Does any one has a solution? Thank you for help.

share|improve this question

The problem disappears after the driver is re-installed.

share|improve this answer
Please mark it as solved. :) – rjkrocks Mar 19 '12 at 19:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.