Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Xubuntu 11.10. When I log out and in (without restarting the computer) I am always required to chose a session and provide a password for entering that session. But when I restart the computer I am logged directly into my last session (or asked to chose between my saved sessions - as an already logged user - , if I check to be prompted on login) without any password being asked.

In all the other normal circumstances I am asked for my password (installing in terminal, accessing Synaptic, using root access etc) - except when opening my computer, which is odd. In Setting Manager, Sessions and Startup, I see (and have checked) the options regarding the login, logout and saving sessions but there seems to be no option for the startup as such, just for sessions. Is there such an option? There must be, I have the impression that after the first OS installation (some 4 months ago) I was beeing asked for password when starting my PC. How could I turn that back?

-- Considering some answers I got, I add the following: I cannot find where to set the login window to appear (the one that in Ubuntu is System>Administration>Login Window). If I set to be prompted upon login, as I said (in Setting Manager, Sessions and Startup), that is a different matter: I am in fact already logged in as user when asked to chose between user-saved sessions. I don't seem to find the settings for System--> Login Window so as to check the option to be prompted to chose sessions (even Ubuntu or Lubuntu sessions if installed) AT STARTUP. --

share|improve this question
    
In standard Ubuntu you go to Users and Groups and tick a box to require a password or not when logging in. I am not familiar with Xubuntu and at the moment I am using 12.04 Beta 1 which does this differently. Have you looked in Users and Groups or the equivalent in Xubuntu? –  grahammechanical Mar 16 '12 at 13:56
    
It looks like password is enabled for logging in. I am asked for password if I am already logged out and want to be logged in BUT NOT after startup. It is as if shutting down my computer will not log me out of the current session or something. I think I can get what I want if before shutting down I log out first and shut down the computer from the small right upper corner –  cipricus Mar 16 '12 at 14:18

1 Answer 1

up vote 11 down vote accepted

In the file /etc/lightdm/lightdm.conf, comment out the line starting with autologin-user=.

For the record, in 'Applications Menu > System > Users and Groups' you can toggle the option 'Don't ask for password on login'. However, lightdm.conf apparently overrides this on startup. As far as I can tell, there is no way to change this through a GUI.

share|improve this answer
    
In Applications Menu > System > Users and Groups I set to be asked for password at login. The problem is that upon startup I am not asked to log in, I am already logged in without password as if I had been shutting down without logging out. . –  cipricus Mar 16 '12 at 14:36
    
@cipricus I understand the issue, as I am also using Xubuntu 11.10. Did you try editing lightdm.conf? –  bessman Mar 16 '12 at 14:37
    
Will report soon. But is it not that too a setting to ask for pass for logging in? That is already set. I want the password. Please watch my answer in a few minutes. thanks –  cipricus Mar 16 '12 at 14:39
    
lightdm.conf looks like that:[SeatDefaults] autologin-guest=false autologin-user=myname autologin-user-timeout=0 autologin-session=lightdm-autologin user-session=xubuntu greeter-session=lightdm-gtk-greeter --- what should I edit to be asked for pass (I mean to be confronted by that option that I get if I just log out) also after shuting down my pc? –  cipricus Mar 16 '12 at 14:43
2  
@cipricus Changing 'username' to 'false' works. Another way to do it is to comment out the entire line by appending the character # to the beginning of it. Both methods achieve the same result, which is to prompt you for your password at startup. –  bessman Mar 16 '12 at 14:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.