Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 2008 white 13.3 inch macbook that now solely runs ubuntu. However, I cannot get wifi or cable to work on it. Regarding the cable, it atleast tries to connect but eventually disconnects from the wired network.


Here is the output for lspci (pastebin)


I tried installing b43-fwcutter and firmware-b43 but get errors. (I loaded them from a thumb drive and tried sudo dpkg -i). I cannot understand these instructions from the documentation, as I cannot locate the pool directory.

b43-fwcutter is located on the Ubuntu install media under ../pool/main/b/b43-fwcutter/ and patch is located under ../pool/main/p/patch/ or both in the official repositories online.

Note: In some versions (10.04 and 11.04 at least) there is not a /pool/main/p/patch/ If this file is missing then you don't need it. In this case you only need to install /pool/main/b/b43-fwcutter by following the instructions below.


Further information:

> uname -m
Linux monadist-MacBook 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

> rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no



> sudo lshw -class network
PCI (sysfs)
  *-network
       description: Network controller
       product: BCM4321 802.11a/b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:16 memory:d0500000-d0503fff memory:d0000000-d00fffff
  *-network
       description: Ethernet interface
       product: 88E8058 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 13
       serial: 00:1b:63:aa:82:c8
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.28 duplex=full firmware=N/A latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:43 memory:d0400000-d0403fff ioport:2000(size=256) memory:d0800000-d081ffff
  *-network DISABLED
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:1d:4f:fa:a7:52
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.0.0-12-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

I have the appropriate b43-fwcutter and firmware-b43 deb files loaded in my home directory. However, when I try:

$ sudo dpkg -i b43-fwcutter_011-5_amd64.deb

I get the error

(Reading database ... 124194 files and directories currently installed.)
Preparing to replace b43-fwcutter 1:011-5 (using b43-fwcutter_011-5_amd64.deb) ...
Unpacking replacement b43-fwcutter ...
Setting up b43-fwcutter (1:011-5) ...
--2012-03-27 09:49:07--  http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
Resolving downloads.openwrt.org... failed: Name or service not known.
wget: unable to resolve host address `downloads.openwrt.org'
dpkg: error processing b43-fwcutter (--install):
 subprocess installed post-installation script returned error exit status 4
Processing triggers for man-db ...
Errors were encountered while processing:
 b43-fwcutter

While installing firmware:

[~]$ sudo dpkg -i firmware-b43-installer_4.150.10.5-4_all.deb 
[sudo] password for username: 
(Reading database ... 124194 files and directories currently installed.)
Preparing to replace firmware-b43-installer 4.150.10.5-4 (using firmware-b43-installer_4.150.10.5-4_all.deb) ...
Deleting old extracted firmware...
Unpacking replacement firmware-b43-installer ...
dpkg: dependency problems prevent configuration of firmware-b43-installer:
 firmware-b43-installer depends on b43-fwcutter (>= 1:012); however:
  Version of b43-fwcutter on system is 1:011-5.
dpkg: error processing firmware-b43-installer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 firmware-b43-installer
share|improve this question
add comment

3 Answers

up vote 4 down vote accepted
+250

ok,

The important part of your trace is the following from sudo lshw -class network

configuration: broadcast=yes driver=b43 

This means that you need the b43 driver. This requires the package b43-fwcutter which is normally installed and activated via the Additional Drivers window.

Since you dont have any internet access, you will need to grab hold of another computer that does have internet access.

You'll need something to transfer between the offline PC and the internet connected PC such as a memory stick/CD etc.

Also - you have 11.10 - therefore you will need to grab a copy of the b43-fwcutter from the following location:

http://packages.ubuntu.com/oneiric/b43-fwcutter

Since you have a 64bit computer and 64bit installation you will need the file:

b43-fwcutter_014-9_amd64.deb

You will also need to download the firmware from the following locations:

http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o

http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2

Copy these three files to the offline PC.

to install

Install the b43-cutter deb package that was downloaded

sudo dpkg -i b43-fwcutter_014-9_amd64.deb

Next extract and install the two firmware files that were downloaded:

tar xfvj broadcom-wl-4.150.10.5.tar.bz2
sudo b43-fwcutter -w /lib/firmware wl_apsta-3.130.20.0.o
sudo b43-fwcutter --unsupported -w /lib/firmware broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o

Now reboot.

Re-run the following:

sudo lshw -class network

Your wireless network should NOT say DISABLED

Go to the network manager icon and tick the Network and wireless tick-boxes.

Fire up Firefox and go-to

http://askubuntu.com

Have fun!

(taken but slightly modified from source)

share|improve this answer
add comment

These instructions are for an HP, but it has the same wireless chipset - perhaps they would work for you as well:

This bloggers solution was:

sudo apt-get update
sudo apt-get install firmware-b43-installer
sudo apt-get remove bcmwl-kernel-source
sudo reboot

It may be a shot in the dark, but worth a try.

Here are some possible instructions for installing without any internet connectivity. See the section: "b43 - No Internet access"

share|improve this answer
    
Any instructions for loading these packages via usb? –  yayu Mar 21 '12 at 2:32
    
@yayu added another link I just found for installing without an internet connection - hope this helps you. –  Jayson Rowe Mar 21 '12 at 2:38
    
hmmm installing firmware as a shot in the dark doesn't looks like a safe path... and if you going back in the tunnel, what is that light on the end of it? It's a train coming? –  H_7 Mar 23 '12 at 12:13
    
@H_7 was just trying to help and that was the only solution I found. Perhaps 'shot in the dark' was the wrong term, but I was implying it may not work exactly as in the tutorial as the article was written about an HP, rather than MacBook, even though it was the same wireless chipset. –  Jayson Rowe Mar 23 '12 at 18:24
    
@Jayson Rowe, ya Jayson, no downvotes here, just pointing out this is a risky solution. "install firmware" doesnt sounds good with "shot in the dark". Just wanna know if you have some path back. –  H_7 Mar 23 '12 at 19:25
add comment

enter image description here This is the support page here

Specifics for the MacBook, MacBook Pro and others.

This is the home for Mactel (Intel CPU-based Macintosh Computers) running Ubuntu. Here you'll find all the supported versions of Ubuntu for your Mac, whether it be a Macbook, Macbook Pro, iMac, Air, etc. This page is primarily for (potential) users.

Example snippets from the support page follow: enter image description here This gives the operator directions and advise as to what works "out of the box"

enter image description here

There are two driver options for your macbook pro. The proprietary broadcom drivers, or the open-source kernel ones. The open-source drivers were added to ubuntu 11.04 kernels. Only install the additional drivers if you experience issues with the open source ones.

Note: Should you experience slow connections with the proprietary broadcom drivers when running on battery power then you can find a workaround in this thread: http://ubuntuforums.org/showthread.php?t=1596061#6

Some users find disabling network-manager and enabling wicd, as described in the 10.04 documentation, improves wireless performance.

Wireless BCM4321

STA driver info Located Here

Wifi docs / BCM43xx download and install instrucions

When installing choose 'Enable non-free software' and the Broadcom STA driver should be installed at first boot. If not, enable the driver using the 'Additional Drivers' application and reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.