Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wish to install gcc 4.7 so that I can use some c++11 features.

I downloaded the source, ran ./configure and was told I needed GMP. Downloaded the code for that, hit ./configure and was told I needed m4. But I already have m4 (least that is what synamptic tells me).

What is going on and how can I fix it?

share|improve this question
up vote 56 down vote accepted

You can try this PPA for installing gcc 4.7. Do note that it has packages only for 12.04 and not for 11.10.

Run the following commands in a terminal:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.7

Or, if you prefer a graphical way of installing a PPA, take a look at What are PPAs and how do I use them?.

share|improve this answer
Worked perfectly, thanks again – soandos Apr 1 '12 at 6:46
If you want to replace gcc 4.6 and make gcc 4.7 the default gcc compiler, you have to follow these instructions – thegreendroid Nov 18 '12 at 2:32
I didn't have add-apt-repository installed, I fixed this with sudo apt-get install python-software-properties – dwurf Dec 6 '13 at 0:23


You also most likely need to take care of g++-4.7

So the full commands list will be:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.7 g++-4.7

Also, don't forget to update-alternatives, as suggested here

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.6 
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.7 
sudo update-alternatives --config gcc

This is confirmed to work in Ubuntu 12.04

share|improve this answer
g++ is a subset of gcc, no? – soandos Jul 2 '13 at 2:07
He and many others might be unaware, as I was. The thing is that in various distributions, once you install gcc, g++ got's installed automatically, with this ppa it's not the case and you need to install both separately. – user109764 Jul 2 '13 at 8:57
This is definitely the right answer, the other one is incomplete I think... – Sh3ljohn Aug 13 '13 at 22:09

Search the build directory for config.log files, and search those for the error message. That should give some clues.

BTW, if you don't need 4.7 precisely, you could try installing the gcc-snapshot package. That should have the features you need. It doesn't get installed in the standard place though, if I remember correctly.

share|improve this answer
Where does it get installed? – soandos Oct 30 '12 at 0:29
The full file-list (for 64-bit 12.10) is here: – ams Oct 30 '12 at 11:33

This is a complete guide of how to build from sources gcc-4.7 on Ubuntu 12.04 64 bits:

share|improve this answer
That guide makes the second common mistake given at, making life far more complicated than it needs to be – Jonathan Wakely Feb 20 '13 at 11:40

I have tried and it has worked for me:

Hope that helps! :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.