Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Oneiric on the HP dm1-4142nr (AMD E-450) notebook and with a bit of tweaking everything appears to work except the Bluetooth (BT). After some researching I found that BT is a part of the dreaded Broadcom hybrid BCM4313 hardware that supposedly supplies both. Here's what I've tried so far:

In all tests the hardware key (f12) has been enabled and the top toolbar shows a bluetooth icon as well as wireless icon (single key press toggles both BT and wifi on/off).

I am currently using linux-3.0.0-13-lowlatency kernel but this should have any bearing on the problem as I also tried downloading latest Broadcom driver (hybrid-portsrc_x86_64-v5_100_82_112.tar.gz) from the Broadcom site and successfully built it according to their instructions.

I tried both the brcmsmac driver and the wl driver. Wl driver solves the poor range problem as well as f12 LED light color change (which does not occur when using the brcmsmac driver) to reflect the enabled state. Other than that they both have exact same behavior in respect to this problem.

In all tests at first "rfkill list" did not show any bluetooth devices, until I manually modprobed btusb. Now it lists the following devices:

1: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: no 2: hp-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 6: brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: no

Enabling/disabling devices is properly reflected in the aforesaid list (Hard blocked value changes to yes/no).

"hcitool dev" shows no available devices.

"hcitool -i hp-bluetooth" yields: Invalid device: No such device

Curiously, "lsusb" shows no bluetooth devices: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 001 Device 002: ID 064e:d217 Suyin Corp. Bus 006 Device 002: ID 0a5c:21e3 Broadcom Corp. Bus 002 Device 002: ID 152d:2339 JMicron Technology Corp. / JMicron USA Technology Corp.

Top toolbar shows bluetooth being enabled. Right-clicking on it and selecting properties (that opens BT system settings) shows Bluetooth being disabled and trying to enable it simply reverts back to disabled within a second or two.

The only lead I found so far is that some were able to enable BT in Windows (on dual-booting computers) and then rebooted into Linux at which point BT worked ok. I however do not have a dual-boot on this machine. Besides, having to boot into Windows every time before Linux just to "fix" bluetooth seems hardly like a fix. I did find another thread with a user in identical situation (no dual boot) and no solution to the said problem. Based on this, however, it seems to me there might be some kind of a firmware missing?

Also, has anyone tried ndiswrapper for this setup in hope that might fix the BT issue? If so, is the wifi stable?

Any insight in this matter is greatly appreciated!

share|improve this question
    
I just tested 12.04 beta and there brcmsmac driver allows proper operation of bluetooth. I did not test the other drivers, though. Is there a chance this fix (whatever that may be) will be backported to Oneiric? –  FlabbergastedPickle Mar 15 '12 at 14:33
    
please click the tick button next to your answer to close. thanks. –  fossfreedom Mar 17 '12 at 9:28

1 Answer 1

up vote 2 down vote accepted

I upgraded to 12.04 beta and after patching and installing wl driver (see http://www.mindwerks.net/2011/11/wireless-bcm4312-3-2-kernel for the patch), now both bluetooth and wireless work great!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.