Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With today's updates to 12.04 I can no longer bind gnome-do to either ctrl+alt+space or super+space. With 11.10 it wasn't possible to use super+space, on a fresh install of 12.04 super+space was working properly.

Today it stopped working, if I try to bind control+alt+space then the controlkey shows up in the keyboard binding as Primary.

I am running Unity, which in the past blocked super+space, it seemed to have stopped blocking it on 12.04. It shouldn't affect ctrl+alt+space.


Configuring either binding produces the following error in the gnome-do output:

libdo-WARNING **: Binding 'space' failed!

libdo-WARNING **: Binding 'space' failed!

I'm stuck binding to shift+alt+space.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

This is a combination of two problems:

The super problem is that Unity recently changed to grab the super key entirely - until version 5.6.0 it wolud pass on super keypresses that it didn't use to other applications that had registered bindings, like Do.

The second problem is due to a change in GTK - it's bug #903566 in Do, which is fixed in 0.9 and in Precise. You can temporarily get a fixed Do from the daily builds PPA.

share|improve this answer
    
I'd like to try the recommendation about manually editing the shortcut in the from the bug ( bugs.launchpad.net/do/+bug/903566/comments/2 ) but I can't figure out where the configuration is stored. I thought it was in gconf-editor under /apps/gnome-do/preferences/Do/CorePreferences/SummonKeyBinding but this doesn't appear to update to reflect the current setting in the App and editing it doesn't help. –  johnf Mar 16 '12 at 1:15
    
Unfortunately the daily builds PPA doesn't have builds for precise, the most recent release is oneiric. –  johnf Mar 16 '12 at 12:07
    
Hah! Thanks for reminding me - I should turn on Precise builds! –  RAOF Mar 17 '12 at 22:39
    
And done: the daily builds PPA now also builds for Precise. –  RAOF Mar 17 '12 at 22:46
    
It's working perfectly now, thank you very much RAOF. –  johnf Mar 21 '12 at 1:42

According to TechRepublic:

Under standard GNOME, the key combination to call forth GNOME Do is Super-Space, but the Super key is reserved for two very important functions in Unity. If Super is tapped once, it will call up the search dialog, and if it is pressed and held, the launcher icons will display numbers (see Figure A). The user can then press the number associated with the launcher to launch the application.

So, after you launch GNOME Do, instead of using it to search for an application or file, the very first thing that must be done is to re-configure it to use a different hot key combination so that it doesn’t use the Super key.

Are you using Unity? This may be the fundamental cause. Super shouldn't work with it.

share|improve this answer
    
I am using Unity, I can confirm that it did stop Super+Space in the past (11.10). It was no longer blocking it on 12.04. Regardless, it should not affect ctrl+alt+space. –  johnf Mar 15 '12 at 16:01

Ctrl + Alt + Space works in Gnome 3 (on Ubu 12.04). The key binding for Super-Space does not. Perhaps that's due to a more stingy binding of Super in G3 as well?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.