Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 3TB disk which I want to encrypt. As soon as I create a file system (mkfs.xfs or ext2-4) in the encrypted partition it outputs "Attempt to read block from file-system resulted in short read while creating root dir".

If I don't encrypt, this error doesn't appear and I can use the disk like expected.

I created a GPT partition table with parted like this:

# parted /dev/sdb
mklabel gpt
mk primary 0.00TB 3.00TB
quit

This worked fine.

I then created the crypt-container and decrypted it like this:

# cryptsetup luksFormat /dev/sdb
# cryptsetup luksOpen /dev/sdb1 storage

This worked, too.

Now I tried to create the file system:

# mkfs.xfs /dev/mapper/storage

This resulted in the following error: "Attempt to read block from file-system resulted in short read while creating root dir".

I tried to create a LVM-container and create the crypt-container inside. This works, but after copying some files on the disk it crashes and reports I/O-errors every time I try to access it.

I checked the disk for errors in Linux and with the Seagate-tool in Windows. No errors were found.

I experimented by creating <=2TB crypt-partitions and managed to create file-systems without errors. But when I resize the containers it doesn't work anymore.

share|improve this question
2  
Bug report? Some sources indicate that error is often failing or sluggish disk, but given the inordinately large size of the disk I'm guessing bug report. references: comments.gmane.org/gmane.linux.kernel.device-mapper.devel/14600 ubuntuforums.org/showthread.php?t=837867 –  hbdgaf Mar 15 '12 at 11:07

1 Answer 1

up vote 2 down vote accepted

The error was caused by a failing disk. I wiped it several times and finally got an error after 105GB and the disk crashed.

I got a replacement and I could get it working on the first try. Also, I could wipe it until the last bit without an error. The last bit threw a "not enough disk space" error, though. Reliable. I don't know if I should be worried...

For everyone who has a similar problem: You can wipe your disk like this:

# dd if=/dev/zero of=/dev/sdb bs=1M

Make sure /dev/sdb is the right disk, you'll lose all your data on it! It should not display any error and end with a summary.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.