Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Ubuntu Restricted Extras in the Terminal. Now when ever I try to install an app or something I get this File"/usr/lib/python2.7/dist-packages/aptdaemon/worker.py" line 968, in simulate trans. unauthenticated = self._simulate_help(trans) What do I do?????

share|improve this question

closed as off-topic by Luis Alvarado Apr 23 at 17:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Have you tried this?

Essentially in that thread and the one it links to:sudo dpkg --configure -a
From the man page this:

         Configure  a package which has been unpacked but not yet config‐
              ured.  If -a or --pending  is  given  instead  of  package,  all
              unpacked but unconfigured packages are configured.

So, you're just trying to get your packages in a consistent state. Then asudo apt-get update and sudo apt-get upgrade to get to latest...from the terminal. If it fails, note what packages it complains about.

Then you can force remove/purge/reinstall them.

"How do I purge and re-install"
sudo apt-get remove --purge ubuntu-restricted-*
You may need a -f in there if something is in an inconsistent state.
sudo apt-get autoremove
sudo apt-get install ubuntu-restricted-extras

share|improve this answer
    
ok, now it is back where it was in the terminal Configuring tts-mscorefonts- installer. So I just let it finish? How will I know? Thanks for the help –  Heavyonion Mar 15 '12 at 3:52
    
Yes, let it finish. If you interrupt an installation process it can leave your system in an inconsistent state. If it's going through the fonts, you're probably going to get prompted to agree to something. Agree, and let it run. –  hbdgaf Mar 15 '12 at 3:59
    
If it's still trying at this point, then the package didn't download properly and you need to force purge at least that package. Safer to purge and reinstall restricted-extras –  hbdgaf Mar 15 '12 at 4:34
    
ok how do I purge and reinstall? –  Heavyonion Mar 15 '12 at 6:02
    
say's that E:dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. –  Heavyonion Mar 15 '12 at 6:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.