Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 10.04 workstation that was running Compiz with Restricted nVidia drivers. I setup PAM to use LDAP authentication and mounted /home on NFS.

I can now login via LDAP with NFS homes, but my restricted drivers are gone, and the Hardware Drivers tool doesn't show any restricted drivers as being available. How do I get restricted drivers working again?

share|improve this question
    
I have a local admin account that can be used for sudo purposes, and it works correctly. I'm wondering if the Proprietary Drivers tool has some sort of cache that can be reset? –  Nick Mar 15 '12 at 13:49
    
Does anyone know where the actual nVidia drivers are stored so that I can remove them and start over (or perhaps see if they're still there at all?) –  Nick Mar 15 '12 at 15:07

3 Answers 3

This sounds strange. Did you install the drivers to your "old" home? Since you are now using a new home (which is located on the NFS server), the old one is not active for your account at the moment.

share|improve this answer
    
I used the proprietary drivers tool under System->Administration. No restricted drivers show up as a choice anymore... It's just an empty list. –  Nick Mar 14 '12 at 23:32

I don't know if it's related, but the nvidia faq here has some steps for minor buggy-ness with the driver and PAM:

Q: OpenGL applications exit with the following error message:

        Error: Could not open /dev/nvidiactl because the permissions
        are too restrictive.  Please see the FREQUENTLY ASKED QUESTIONS
        section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
        to correct.

A: It is likely that a security module for the PAM system may be
   changing the permissions on the NVIDIA device files.  In most cases
   this security system works, but it can get confused.  To correct this
   problem it is recommended that you disable this security feature.
   Different Linux distributions have different files to control this;
   please consult with your distributor for the correct method of
   disabling this security feature.  As an example, if your system has
   the file
        /etc/security/console.perms
   then you should edit the file and remove the line that starts with
   "" (we have also received reports that additional references to
    in console.perms must be removed, but this has not been verified
   by NVIDIA).  If instead your system has the file
        /etc/logindevperms
   then you should edit the file and remove the line that lists
   /dev/nvidiactl.  The above steps will prevent the PAM security system
   from modifying the permissions on the NVIDIA device files.  Next,
   you will need to reset the permissions on the device files back
   to their original permissions and owner.  You can do that with the
   following commands:
        chmod 0666 /dev/nvidia* chown root /dev/nvidia*

I understand that's not exactly your issue, but it might be worth looking in to a bit.

share|improve this answer
    
I have two files under /dev/: nvidia0 and nvidiactl. Both are root:root and have crw-rw-rw- permissions, which I believe is correct. –  Nick Mar 15 '12 at 14:57
up vote 0 down vote accepted

Downloading the Nvidia Drivers from Nvidia's website and reinstalling them seems to have fixed the problem.

UPDATE: A few days later the graphics card failed completely. Might have been faulty/failing hardware.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.