Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using awesome-wm now, and was trying to get it working with gnome-shell. I have basically followed those steps: http://awesome.naquadah.org/wiki/Quickly_Setting_up_Awesome_with_Gnome#Ubuntu_11.10

But now I have two panels, one at the bottom and one at the top. Is there any way to get rid of one of those (preferring top panels). If that is not possible, is there a way to load the gnome-shell applets in the top panel? Now it's only displaying the time.

screen: http://i.imgur.com/5sqTv.png

Thanks ;)

share|improve this question
add comment

1 Answer 1

Quote from the same wiki page you linked:

"You will likely want to choose either gnome-panel or awesome's main wibox as your panel. If you choose to disable your wibox, configure your rc.lua to not start it up. If you choose to disable gnome-panel, it is easiest to stop using gnome-session and run your session in the traditional way."

share|improve this answer
    
To add on to that, the system tray is probably inside Awesome's wibox which is under the gnome panel, so I would disable Awesome's wibox because presumably one of the main reasons you're using Awesome inside Gnome instead of standalone is to get the gnome panel stuff. –  Ibrahim Apr 30 '12 at 7:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.