Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I changed the mouse sensitivity/acceleration settings in System Settings\Mouse and Touch Pad. How do I restore these settings back to their default values?

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

What I've found is that deleting the gconf mouse folder resets everything to defaults. The slider bars don't change, must be cached somewhere in gnome.

From a terminal: rm -fr ~/.gconf/desktop/gnome/peripherals/mouse

From Nautilus:

  • Press Ctrl+l
  • Paste or type ~/.gconf/desktop/gnome/peripherals
  • Right click mouse
  • Select Move to Trash
share|improve this answer
    
Does this work with 12.10? –  Kit Roed Mar 20 '13 at 0:47
add comment

In Ubuntu 12.10 per-user mouse settings (and others too) are managed by settings daemon, and their configuration is stored in dconf database. To restore the default settings you want to set the values new users have on those fields = -1 (or resetting them).

Steps to set default per-user settings, using dconf-editor (graphical tool):

  1. Launch dconf-editor. If not installed, install using sudo apt-get install dconf-editor.
  2. Browse/choose directory (on the left side) to /org/gnome/settings-daemon/peripherals/mouse.
  3. Change values of motion-acceleration and motion-trheshold to -1.

Steps to set default per-user settings, using dconf (terminal/console tool):

  1. Check if it's there (run dconf help). If not, install using sudo apt-get install dconf.
  2. Run in terminal dconf reset /org/gnome/settings-daemon/peripherals/mouse/motion-acceleration
  3. Run in terminal dconf reset /org/gnome/settings-daemon/peripherals/mouse/motion-threshold
share|improve this answer
    
Was able to find the values, but changing them didn't make a difference for my mouse. –  mlissner May 3 '13 at 16:24
    
Did you change them only in System Settings? –  mrówa May 3 '13 at 22:16
    
No, these settings didn't appear in my system settings for some reason. Hence trying this method... –  mlissner May 3 '13 at 23:05
    
This worked for me. Sadly whenever I enter the mouse settings applet again, they move back to the minimum values. –  mdsharpe Feb 19 at 18:52
add comment

The default value for both is leftmost - Acceleration is slowest and the Sensitivity is lowest.

enter image description here

share|improve this answer
    
I don't think this is quite true. I believe that the sliders were by default to the left most position when I first opened the app. However, I have also messed with these bars, and now putting them back to the left most position makes my mouse feel god awful slow (which wan't the case after I first installed; 12.04). I can't even get my mouse across the screen anymore without lifting my mouse. –  PKKid Apr 30 '12 at 4:01
    
I have the same experience @PKKid. I've tried the accepted solution to no avail. I don't mind the speed/acceleration I've set the mouse too, but for some reason whenever moving from my right monitor to my left if I'm not going painfully slow my pointer ends up completely to the left side of my left monitor. –  powerj1984 Sep 24 '12 at 22:16
add comment

While this doesn't directly answer your question. I found that the sliders to the left most position did not feel like the defaults at all after messing with them. After some research I found out the following information to fine tune how the mouse works which may be helpful to some other visiting this page.


It looks like there is a rather complex set of tuning functions available for setting the mouse behavior. You can see all the settings here. The most important ones are the Acceleration Profile and Constant Deceleration. Here's what I found works for me, and how I set the values.

First we want to see what the properties are:

xinput list             # Displays connected devices (Find ID of your mouse)
xinput list-props <ID>  # Displays properties of device

Next, I put my desired settings inside a script called fixmouse.sh. I had to tinker a bit before I found these preferred values.

xinput set-prop 'Logitech USB-PS/2 Optical Mouse' 'Device Accel Profile' 2
xinput set-prop 'Logitech USB-PS/2 Optical Mouse' 'Device Accel Constant Deceleration' 2

Run the script and your mouse settings will take affect immediately. Your mileage may vary. Play with the different profiles and values for deceleration. The higher the Deceleration, the slower the mouse moves. It might also be a good idea to drop the initial values from xinput list-props to another script called unfixmouse.sh while you are tinkering.

share|improve this answer
    
Thanks, PKKid. I'd upvote for this if I had enough rep, it's nice to have a bit more detail and control than the GUI provides. –  Michael Cotterall Apr 30 '12 at 17:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.