Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, I messed up. I installed ubuntu 11.10, installed awesome wm and removed unity, to have something to fall back on, I also installed gnome-session-fallback.

I was messing around and did the following, because the awesome wiki told me to:

gconftool-2 --type bool --set /apps/nautilus/preferences/show_desktop False
# Still disable the buggy Nautilus desktop thing
gconftool-2 --type string --set /desktop/gnome/session/required_components/windowmanager awesome
# sets awesome as wm

Now here's what's wrong: I can start up decently, and then I get into a login window (that of gnome-session-fallback). I enter my username, select the preferred window manager (awesome in my case) and enter my password. It accepts these, but then hold for a second and just opens the login window again, in effect preventing me from actually logging in.

I also tried gconftool-2 --unset (from the tty) on these settings, but that didn't work either.

What can I do to revert the gconftool-2 settings to something that should work? I tried apt-get purging gnome-session-fallback and lightdm, and then installing them again, but that didn't work.

share|improve this question

closed as too localized by fossfreedom Jun 24 '12 at 21:30

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you solved your issue? –  pl1nk Jun 24 '12 at 13:13
    
@pl1nk: yes I threw out gnome, ... In fact I threw out ubuntu and switched to Arch, which has never let me down since. –  romeovs Jun 24 '12 at 15:54

1 Answer 1

Try these (after reinstalling gnome-session-fallback):

gconftool-2 --type bool --set /apps/nautilus/preferences/show_desktop True
gconftool-2 --type string --set /desktop/gnome/session/required_components/windowmanager /usr/bin/metacity
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.