Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The problem started when I was trying to download the 12.04 Beta 1 but didn't have sufficient time to complete the install. As I try to upgrade or re-download 12.04 I get the message "Not all updates can be installed" with the choice to Partial Upgrade or close.

Partial Upgrade gives me:

An upgrade from 'precise' to 'oneiric' is not supported with this tool.

Close gives me:

Software index is broken

It is impossible to install or remove any software. Please use the package manager "Synaptic" or run "sudo apt-get install -f" in a terminal to fix this issue at first.

The Synaptic suggestion doesn't work as well. The command gives me

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Any suggestions?

share|improve this question

You can open a terminal and enter sudo dpkg --configure -a.

share|improve this answer

Here is what worked for me:

sudo -i

and then

dpkg --configure -a

That worked, and I could now run the command:

apt-get dist-upgrade
share|improve this answer
i had shutdown the system due to hang up when it was upgrading ubuntu. the system didnt start up. then i restored to earlier-> dwonloaded broken packages but not able to upgrade-> it said no latest version available n the upgrade had not completed. so finally followed this n it worked. so, +1 – Angelin Nadar May 16 '12 at 4:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.