Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on the ubuntu 12.04 64bit Beta right now. Having a more exotic partition setup: - EFI - /boot PARTITION (fat) - LVM (encrypted) | |- /root |- /home |- /swap

Now I noticed that my boot partition doesn't get updated by the Update Manager. Thus new kernel images etc. get downloaded but to another /boot folder on the /root partition. Same is happening when I try to make changes to grub from cli, grub-update only applies to the /root-/boot stuff, leaving my boot process uneffected...

The whole setup has been done on a fresh install using the alternate cd/dvd. If I remember correctly I ran into this issue on 10.04 LTS, too (never solved it there because we went on using centos).

Any insights, tipps or solutions? Thanks.

cat /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/mapper/agw--x220-root /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=8EBB-0ACF  /boot/efi       vfat    defaults        0       1
/dev/mapper/agw--x220-home /home           ext4    defaults,user_xattr        0       2
/dev/mapper/agw--x220-swap_1 none            swap    sw              0       0
share|improve this question

Here is the solution to my question:

identify your /boot partition's UUID:

# blkid

Use that UUID to update your /etc/fstab table to mount your boot partition automatically:

UUID=PUT-YOUR-UUID-HERE /boot ext2 defaults 0 0

To keep things clean I deleted the content of the current /boot directory (make a backup):

sudo rm /boot/*

You will probably get an error message regarding your EFI subdirectory (if you use UEFI). Thats no problem, just skip the error message.

Now reboot.

In case you had a newer kernel image installed you might want to update the /boot partition/directory. I did it this way:

sudo aptitude update
sudo aptitude reinstall linux-image-generic
sudo update-initramfs -u

You should now see a new file named "initrd.img-3..." in your /boot directory. Assuming you had this kernel image installed previously, check your backup of the old /boot directory and copy the matching "abi...", "config...", "system..." and "vmlinux..." files to your /boot directory (must be root to do this, so use sudo). Then use the terminal again:

sudo update-initramfs -u
sudo update-grub

You should no be set and boot you computer from your /boot partition (as intended) and this is also mounted as /boot on startup, thus when you now update your system the correct /boot directory is updated as well.

NOTE: I ran into another minor bug when using update-grub on a separate /boot-partition. I got an error message on startup. It is related to grub not being able to find font files and then failing to set gfxmode. No biggie, your system will boot just fine...but fix this you will simply have to copy the font files to /boot/grub Here is the related bug and here the fix (see comment #24)

share|improve this answer

It is the EFI system partition that needs to be fat, and that is normally mounted in /boot/efi. /boot can simply be in your root filesystem, which can be an LVM logical volume.

If you do have a /boot partition, then it needs to be mounted there if you want it to be used, so make sure it is in /etc/fstab.

share|improve this answer
good the issue here is that my /boot partition is being used on boot, but not being mounted and ubuntu doesn't see/use it...right? How would I make that transition to mount and use the /boot partition now (after installation, running system)??? I updated the original post and added the fstab. – meceso Mar 15 '12 at 16:51
@meceso, yes... add a line for it in /etc/fstab. Once you have it working and are updating correctly, you may want to manually unmount /boot, revealing any files in the /boot directory of the root fs that are now ignored, and delete them, then remount /boot. – psusi Mar 15 '12 at 17:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.