Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I love Ubuntu but My # 1 issue with the 173 nVidia drivers that I have installed is the size of my desktop icons! They are way too big (everything is too big). I would like to improve on the resolution my Display is set to by upgrading to a better driver!

read my pastie please It is full of system info and logs (about the issue at hand)

I need help please I can't afford to upgrade to new hardware right now <

share|improve this question

marked as duplicate by Jorge Castro, Kevin Bowen, Eric Carvalho, Basharat Sialvi, green7 Apr 25 '13 at 7:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Best way I have installed NVIDIA drivers is by downloading them directly from the NVIDIA website. Then from there, I use Terminal and run the following commands to install them (note filename name may differ from what you download:

$sudo chmod a+x

$sudo ./

share|improve this answer

Try sudo apt-get install nvidia-settings. Then try to launch nvidia-settings using the terminal and try to adjust the resolution from there.

share|improve this answer
Please re-edit your question with this info - it is very difficult to read this in comment format. thanks. – fossfreedom Mar 13 '12 at 22:44

I found my answer on By adding the ppa from “xorg crack pushers” team I solved my display issues! There is one big issue though, you might lose access to Unity 3D.

I think Unity 3D does not like xorg-edgers updates. But, I use Gnome-shell and so, not being able to use Unity-3D is fine.

So, here is what I did:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current

My old driver was removed and the current driver 295.20 was installed.

After that, when I logged into Unity 3D, all that loaded was the wallpaper. So, I went to one of the tty's. To get to the tty's, press the following keyboard combination:


sudo reboot

I then logged back in. gnome-shell or Unity 2D or KDE all worked fine.

nVidia X server settings works like it should and I set my Display from 1024x768 to 1280x1024.

You have to purge xorg-edgers from your system to get Unity 3D to work again.

Unity Doesn't run after upgrading via xorg-edgers

I will wait for Ubuntu 12.04 to see if Unity 3D works for me again!

share|improve this answer
Unity 3D is once again working on my system I updated this morning using via-xorg-edgers! Just read the Pastie check out the update manage history log. Maybe someone can explain what happened. – blackipods Mar 24 '12 at 11:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.