Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's that time of year again when I'm trying to print off all my tax forms. When I print to my printer, an HP PSC-750, from Ubuntu, I consistently get a 1/2" margin at the top of the document. According to this page however, the top margin required by the printer is only .07".

In previous releases of Ubuntu (such as the 10.04 prerelease I was running this time last year), it appears that something in the print pipeline would automatically scale the output to fit these margins. This year, 12.04 Beta is trying to use the whole page (unless I manually tell it to scale and manually tell it to use a 1/2" margin), resulting in part of the text being cut off.

Does anyone know why, when using the default print driver provided by Ubuntu, the printer would behave this way? I see the same behavior whether I have the printer connected directly to my laptop, or if I use my Debian stable server as a print server. Is this a problem with the printer itself? The strange 1/2" top margin has always been a problem since it was first purchased, but I've only ever used it with Linux, never with Windows, so I can't say whether this is a Linux-specific problem.

share|improve this question
2  
Same problem here. Unable to get margins less then 20mm I hate this! Maybe it is this bug? #994630? –  Eveline Bernard May 31 '12 at 19:53

7 Answers 7

It sounds like it's not printing with the correct page size. Please check the default setting in System Settings / Printing / [your printer] / Properties / Printer Options.

If you are sure the page size is correct, please file a bug on launchpad and attach the CUPS error log right after you printed something with wrong margins [1]. Feel free to assign me so that I find it quicker ;) (larsu)

[1] https://wiki.ubuntu.com/DebuggingPrintingProblems#CUPS_error_log

share|improve this answer

I'm having the same problem. My printouts are cut.

System is Ubuntu 12.04 LTS with HP Photosmart 6510 printer.

Here what I found (talking about A4 and cm, however, should be the same with Letter and inches, I just cannot try it with my setup)

  1. Printer (at least mine) has a "scale-to-fit" options which allows pdf to be rendered properly. The printout is scaled down, so it is smaller, but the margins are looking good.

    Printers -> -> Job Options -> scale-to-fit

    This is of course not acceptable for predefined paper positions or if I want data to be as large as possible (for me Music Sheets and Labels for CDs)

    so there is

  2. the option to use the full paper size

    During print:

    Page Setup -> Paper Size -> ... Borderless ...

    This allows to print pages without borders.

Hope this helps to solve you problem as well ;-)

Klaus

share|improve this answer
    
(2.) Works like a charm ! –  cebor Oct 1 '13 at 19:54

Solved by deleting printer in System->Administration->Printers and reinstalling it with another driver.

Ubuntu is 12.04 LTS (Precise).

Printer is HP Officejet G55.

Actual (good) driver is "HP OfficeJet G55 - CUPS+Gutenprint v5.2.8-pre1".

Previous (bad) driver was "HP Officejet g55, hpcups 3.12.2".

Noted that Ubuntu "Printer test page" border adjust to hardware margins.

share|improve this answer

Historically, many printers have not been able to print to the edges of the paper. It quickly became standard practice to leave a 1/2" margin all the way around. In some cases it is even enforced by printer drivers. It looks better, is convenient for holding papers in your hands, for binding them on the left or top, and for writing notes in the margins so today most programs default to having 1/2" margins.

If your printer driver will permit it, most programs that can print will also allow you to adjust the margins. You may even be able to set the default margins in whatever program(s) you use.

share|improve this answer

I solved this issue - HP Officejet 6500 Wireless and 12.04 LTS - by changing the driver. First go the the printer window and remove the printer. Then add a new printer and choose the proper driver (the one including hpcups was the wrong one and the one including hpijs was ok).

Margins are now back to normal.

share|improve this answer
    
Can you please add the steps to achieve what you've done. –  Uri Herrera Feb 17 '13 at 20:49

Again a problem with Printer Margins caused by MusicSheets on PDF using Ubuntu 12.04 (same on 13.10).

Problem: Header is not printed correctly, header text is simply cut in the first lines.

What I did (Evince GNOME Document Viewer 3.4.0 on Ubuntu 12.04.3 LTS):

Print with following options set during printing:

.. to allow maximum output

Page setup -> Paper size = A4 Borderless 210x297mm

... to show headers properly

Page Handling -> Page Scaling = Fit to Printable Area

Page Handling -> Select page size using document page size = tick option to select

... and everything is fine and pretty!

share|improve this answer

Since latest versions (in mind 13.10, 14.04) have fall down this option you may take the command line way, to list printer options use lptoptions -p <printer name> to define options use lpoptions -p <printer name> -o option=value

For this precise issue, you should use lpoptions -p <printer name> -o fitplot

And after this command you will get the option fitplot=true listed.

Have a nice day!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.