Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I enable compiz effects on Gnome3 on ubuntu 11.10?

I already installed ccsm and compiz-plugins-extra.

What else should I do?

share|improve this question
    
Welcome to Ask Ubuntu! By "GNOME 3", are you referring to the GNOME Shell interface or GNOME Classic? You can't use Compiz in GNOME Shell, but you can in Classic. –  Christopher Kyle Horton Mar 14 '12 at 8:14
    
Related (but not a duplicate): askubuntu.com/q/8276/18612 –  Christopher Kyle Horton Mar 14 '12 at 8:16
    
possible duplicate of How do I enable compiz in Gnome Classic? –  Christopher Kyle Horton Mar 14 '12 at 8:44

3 Answers 3

up vote 7 down vote accepted

I'm sorry for bad news but Gnome3 will not work with Compiz as it has its own windows manager compositor called Mutter/Clutter. However, if you will use Gnome 2 you will be able to run Compiz and enjoy its effects.

share|improve this answer
3  
Technically, GNOME Classic is GNOME 3, as is GNOME Shell. We must be careful with terminology here. –  Christopher Kyle Horton Mar 14 '12 at 8:13
    
Mutter and compiz are both compositing window managers that make use of 3d acceleration. Gnome 3's shell relies on mutter in the same was as Unity3d relies on compiz: you cannot switch window managers unless you also stop using gnome-shell. On the other hand, mutter does a lot of the same things that compiz does and does provide some similar effects, though without any of the same emphasis on customisability - customising it is extremely limited if possible at all - for the most part you are stuck with it as it is. It's designed more to just work and not make itself obvious. –  neon_overload Oct 5 '12 at 6:47

Install CompizConfig Settings Manager. It is in the Software Center.

share|improve this answer
    
It's worth noting that this will work only with GNOME Classic. It won't work with GNOME Shell as that uses Mutter instead of Compiz. –  Christopher Kyle Horton Mar 14 '12 at 8:12
    
@WarriorIng64 Why would this work with GNOME Classic? GNOME Classic uses metacity, not compiz. Unity (but not Unity 2D) uses compiz. –  Eliah Kagan Jul 5 '12 at 12:34
    
@EliahKagan GNOME Classic can use Compiz too. For more information, see How do I enable compiz in Gnome Classic? (which is solved, and suggested above as a duplicate). –  Christopher Kyle Horton Jul 6 '12 at 4:04

Gnome 3 doesn't work with Compiz because the developers of it are trying to make an easier desktop.

But if you want to try (WARNING MAY BREAK SYSTEM)

compiz --replace

Although altogether if you want Compiz effects on GNOME use GNOME 2. it's less of a hassle and works. Although it won't surprise me if a hacker that is seasoned finds a way to make it work on GNOME 3. You could also use unity to use Compiz Effects too. I use unity and my compiz effects work great. cheers CJ

share|improve this answer
    
+1 Why was this down voted? –  Hubro Aug 13 '13 at 9:08
    
Warning ignored, system broke. –  Jeff Oct 24 '13 at 14:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.