Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

this is my first question about Ubuntu :)

Since this morning when I log out (top right icon, log out) I don't get the usual GUI login screen but I get this instead:

http://img802.imageshack.us/img802/5637/photovu.jpg

If I log in with the Ubuntu 2D option enabled everything works flawlessly.

Can somebody please suggest some step to take to understand what is going on? It looks like the X server gets stuck...

I can provide logs or whatever can be useful.

Thank you in advance for any suggestion.

Gia

share|improve this question
    
I get the same thing too but there is totally a blank (black) screen. I have to force the machine to reboot. This happened all of a sudden and I think the last batch of updates made it so. Is this related to LightDM? That was the update I noticed most recently that is likely related to this issue. –  Marky Mar 18 '12 at 15:48
1  
It seems that you might have a problem with your Graphic card. Which is your graphic card? Also you can try pressing Ctrl+Alt+F1, login in the console there and type: sudo init 2. Then go back with Ctrl+Alt+F7 and you should see the login screen. This is only a workaround, there must be an issue in the configuration. –  Christian Vielma Apr 11 '12 at 18:15
add comment

1 Answer 1

Like Christian said, it seems like you have a problem in the graphics configuration.

What graphics card are you using? Did you install proprietary drivers, or are you using the standard drivers? Did you update the drivers at all?

To find the details of your driver, run lshw -class video, and look for the line with "configuration". The loaded driver is prefixed with "driver:".

Sample output:

~$ > sudo lshw -class video
   *-display
       description: VGA compatible controller
       product: GT216 [Quadro FX 880M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:cc000000-ccffffff memory:d0000000-dfffffff memory:ce000000-cfffffff ioport:2000(size=128) memory:cd000000-cd07ffff 

In my case, since I am using the NVidia prop. drivers, I can check the driver version by running dpkg -l | grep nvidia which returns:

~# > dpkg -l | grep nvidia
ii  nvidia-common                          1:0.2.44                                Find obsolete NVIDIA drivers
ii  nvidia-current                         295.40-0ubuntu1                         NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                        295.33-0ubuntu1                         Tool of configuring the NVIDIA graphics driver




There could also be something wrong with the X Server configuration in the file xorg.conf. Open up that file in a text editor, and paste the contents here.

~$ > sudo -s                            /* enter root */
~# > find / -name 'xorg.conf'           /* find file, search in all directories */
/etc/X11/xorg.conf
~# > exit                               /* exit root */
exit
~$ > gedit /etc/X11/xorg.conf           /* open file in editor */

Depending on how that file looks, you can reset the xorg.conf file using the terminal by doing sudo dpkg-reconfigure -phigh xserver-xorg which will automatically generate an xorg.conf file while backing up the current one.

You can also delete the xorg.conf file. Then restart the X session with startx. Doing so will create a brand new xorg.conf file with the absence of not having one.

Hope that helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.