Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to follow this guide: but it does'nt seem to be upgraded. The dhcpd.conf file is in /etc/dhcp and not in /etc/dhcp3. But a worse problem is that I can't find /etc/default/dhcp3-server at all. How would I do this in Ubuntu 11.10?

share|improve this question
up vote 2 down vote accepted

When you are logged in:

  • Go to Network menu in the panel.
  • Navigate to "Edit connections".
  • When that window opens, select "Auto eth0", and press "Edit" (This assumes that you are connected to the Internet on some other port, for example wlan0 using wireless).
  • A new window will open. Navigate to the tab titled "IPv4 Settings", and change the Method to "Shared to other computers".

After restarting the computer, you should now be able to plug in any computer into your other Ethernet port or share through your wireless card.

share|improve this answer
Oh, that seemed alot simplier than what I tried. Unfortunatly I could'nt get it to work. But I should try a little more and get back... – Niclas Nilsson Mar 13 '12 at 19:32

What is wrong with /etc/network/interface ? \

Anyway, I had the same problem, however on 12.04. I tried edm's fix but it didn't help. Then I tried changing the method to "only local" for eth0 and then changing the method for wlan0 to "shared to other computers".

Then by using "ifconfig" in terminal I found that eth0 had changed IP to, so I used that IP as gateway on my other device (in my case a Raspberry Pi) and took as IP on my device. It works for me now; I didn't really need the dhcp server anyway.

share|improve this answer
Very interesting. I really never got it working and gave up. My question was also regarding a Raspberry Pi. So now I will try again... – Niclas Nilsson Nov 24 '12 at 19:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.