Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't install RMagick because of the following dependency problem after trying sudo apt-get install libmagick9-dev (required according to this) on Ubuntu 10.0.4:

Note, selecting libmagickwand-dev instead of libmagick9-dev Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:
    libmagickwand-dev:
        Depends: libmagickwand2 (= 7:6.5.7.8-1ubuntu1.1) but it is not going to be installed
        Depends: libmagickcore2-extra (= 7:6.5.7.8-1ubuntu1.1) but it is not going to be installed
        Depends: libmagickcore-dev (= 7:6.5.7.8-1ubuntu1.1) but it is not going to be installed

Trying to apt-get install libmagickwand2, I get this:

> The following packages have unmet dependencies:   libmagickwand2:
> Depends: libice6 (>= 1:1.0.0) but it is not installable
>                   Depends: libjpeg62 but it is not installable
>                   Depends: libmagickcore2 (>= 7:6.5.7.8) but it is not going to be installed
>                   Depends: libsm6 but it is not installable
>                   Depends: libtiff4 but it is not going to be installed
>                   Depends: libxt6 but it is not installable
share|improve this question
add comment

3 Answers 3

up vote 15 down vote accepted

Okay I seem to have solved this with apt-get install imagemagick libmagickwand-dev, so libmagick9-dev wasn't necessary.

share|improve this answer
1  
This worked for me. Just want to point out that require 'rmagick' will still not work. You have to use require 'RMagick'. –  ayckoster Nov 7 '12 at 20:11
    
This doesn't work for me. I get: libmagickwand-dev : Depends: libmagickcore-dev (= 8:6.6.0.4-3ubuntu1.2) but it is not going to be installed –  jackocnr Nov 19 '12 at 12:44
    
same here... getting this error: gist.github.com/4709742 –  TrinitronX Feb 4 '13 at 21:10
add comment

I had this problem on Ubuntu 11.10, and @mahemoff's solution didn't work for me. In the end I uninstalled everything to do with ImageMagick, and then compiled the latest version of ImageMagick from source, and then rmagick installed just fine.

share|improve this answer
add comment

Try this: https://github.com/maddox/magick-installer

That worked really well for me where apt-get and brew failed

share|improve this answer
1  
The software at the link states supported OS: Mac OS X 6 and 7. Please specify if this worked at ubuntu at all. –  aquaherd Feb 24 '13 at 22:23
    
Sorry, only tried it on OSX –  Jarrett Streebin Mar 22 '13 at 13:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.