Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello fine Gentlemen,

i have the following problem and i primarily want to have a way how to analyse this. My problem is that somehow Ubuntu keeps locking me in a certain window/editor. i can then not switch to another one using the mouse or Keyboard. I can however close the window, giving the focus to another window.

i can:

  1. Move the cursor within the window that contains the focus
  2. write in the window that has the focus
  3. Click in window that has the focus
  4. Click on another window, wait some time and it will switch to the new window.

i can't:

  1. switch to another window at my convenience
  2. reproduce the problem because it just comes and goes
  3. fix the problem via a restart, so it should not be processor load

How can i figure out why this is happening? How can i possibly fix it? What additional information do i need to specify the problem, so i can look for a solution?

edit 1: I am using the latest version of Ubuntu (Ubuntu 10.04 LTS - the Lucid Lynx) How do i find out my Desktop environment?

share|improve this question
    
What version of ubuntu are you using? Also what desktop environment (Unity or Unity-2D)? –  edm Mar 13 '12 at 10:54
    
@tarrasch: Unity is not available in 10.04LTS. The default is called Gnome Panel, sometimes also called Gnome Classic, Ubuntu Classic and recently, Gnome Fallback. –  Jo-Erlend Schinstad Mar 13 '12 at 13:00
    
thanks,updated it –  tarrasch Mar 13 '12 at 13:02
    
Oh. Restarting does not make the problem go away? –  Jo-Erlend Schinstad Mar 13 '12 at 13:10

1 Answer 1

This sounds like a problem with Compiz, though it's difficult to be sure based on the information you provide. But you can test it yourself the next time you experience this; press Alt+F2 and enter compiz --replace.

You should expect the screen to flicker a little bit, and then everything should be fine. If it works, then that confirms that the problem is with Compiz. In that case, in order to make sure it doesn't happen again, you can choose No effects in System > Preferences > Appearance > Desktop Effects. (I haven't used 10.04 in a while, so the location might not be entirely correct. If not, just look for it in System > Preferences. You'll find it).

Changing the setting to No effects means switching to Metacity, which is a different window manager and won't have the same problems.

share|improve this answer
    
compiz --replace lets the screen flicker alright. I now have some new visual effects somehow. I disabled all effects, but the problem still persists. How can i give you more information? –  tarrasch Mar 13 '12 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.