Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Heimdall is program used for rooting a Samsung Galaxy S II phone (and other Android phones).

When I attempt to open (with the GDebi Package installer) the Heimdall Frontend 1.3.1 binary for Debian Linux (AMD64 / Intel 64), I get this error message:

Error: Dependency is not satisfiable: heimdall (>= 1.3.0)

I also get the following error message when I try to open (again with the GDebi Package installer) the Heimdall 1.3.1 Command Line binary for Debian Linux (AMD64 / Intel 64):

Error: Dependency is not satisfiable: libusb-1.0-0 (>= 2:1.0.8)

What do I need to do so as not to get these error messages. I'm running 64-bit Karmic, but others running Ubuntu 11.10 are getting similar messages.

share|improve this question
add comment

1 Answer

  1. In the Heimdall website, the author clearly states that:

    To be able to Install Heimdall-Frontend, Heimdall (Commandline) must be installed first.

so install heimdall (commandline) first.

2.The library you have is outdated, you need a newer libusb version.

I'm running Xubuntu 11.10, and I have installed Heimdall, and I didn't get the libusb error, since you're using karmic.. U_P_G_R_A_D_E.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.