Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Mac PowerBook G4.

It has the Mac OS X Version 10.5.8 on it.

I would love to change it to Ubuntu but the last time I tried it wouldn't register the disc.

Any ideas if I need an older version or what needs to be installed in a certain way?

share|improve this question
Here's a good place to start on the installation: – Mordoc Mar 13 '12 at 1:32
a start would be… – rubo77 Aug 7 '13 at 10:10

I'm not sure what you mean by "wouldn't register the disc" but to boot an older iBook / PowerBook from the optical drive, just hold down the C button as soon as you power on.

Another option is to boot into OpenFirmware. This can be done by holding down Cmd-Option-O-F as you power on. Once OpenFirmware has started (a white screen with a short message and a simpole prompt) enter the command: boot cd

I hope this helps. I'm going from memory.

Edit for Addition:

Also, just a warning: Years ago when I used Linux on a MacBook there was no Linux driver available for the Broadcom wifi chipset that Apple used in their laptops. At the time, the only option was to use a usb attached wifi device. This may no longer be an issue.

share|improve this answer

A start would be this tutorial for Lubuntu 12.04

Lubuntu is optimized for old computers.

the latest Images you find here: (currently 13.04) use the "Mac (PowerPC) and IBM-PPC (POWER5) desktop image" in

I tried it on a PowerMac G4 and it seems to work. (although, while it's trying to install, I get the message

!! Select and install software
Installation step failed.
An installation step failed. You can try to run the following item again from the menu, or skip it and choose something else. The failing step is: Load installer components from CD.

But that seems to be due to an error on the old harddrive I inserted into the G4, I see some I/O errors in syslog when I change to the console with Ctrl+Alt+F1 )

share|improve this answer
I asked about this bug in the apple stack here:… – rubo77 Aug 7 '13 at 11:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.