Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Twinview with Oneiric 64bit with a nVidia card.
I have my primary monitor (with DVI) positioned to absolute 0 and my secondary to the right (with HDMI).

My applications open on the primary monitor but all dialog boxes like the following opens on the secondary

  • shutdown
  • reload confirmation on firefox
  • Save changes to document on gedit
  • admin passwords

So when my secondary screen is not on, I am forced to each time Alt + F7 in order to move the new box on the primary display

That's also doing it with some application windows but I got it corrected with CCSM Window Placement


This question seems to be already asked but my problem concerns dialog boxes.

Dual monitor applications opening on wrong monitor

share|improve this question

3 Answers 3

up vote 7 down vote accepted

Same problem here. The fix:

  1. Install ccsm as explained in earlier post.
  2. Go to General->General Options->Display Settings.
  3. From drop down menu of 'Overlapping Output Handling' select 'Prefer smaller output'. (My monitor is smaller than my TV.) Apparently the 'Smart Mode' isn't very smart (at least on my setup).
share|improve this answer
    
I used to be wary of things using the term "smart". Thank you, it seems to work –  Pierre de LESPINAY May 4 '12 at 6:29

If you're using Compiz I find that using the Place Windows plugin is a good way to have predictable windows placement.

You'll need to install the CompizConfig Settings Manager (aka ccsm) to get going. One warning: CCSM can break things if you run around doing things you're not supposed to, so focus on the task at hand :)

I currently have mine set to:

  • Placement Mode: Centred
  • Multi Output Mode: Use output device with pointer
share|improve this answer
    
Thank you, I used these settings and it fixed the problem for application windows but not for the dialog boxes –  Pierre de LESPINAY Mar 13 '12 at 8:09

In ccsm under (Place Windows) you should see (Force placement windows) you can type this "type=dialog" without quotes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.