Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install proprietary nvidia graphics driver I downloaded from nvidia website. It will not install because it says that the "Nouveau kernel driver" needs to be disabled first.

I opened synaptic and uninstalled everything that had nvidia, nouveau, or jockey in its name. It still won't work.

What exactly do I need to do to disable the "Nouveau kernel driver"?

share|improve this question
    
Oli, I'm downloading from NVIDIA because nvidia-96 will not install, see here: askubuntu.com/questions/112206/… –  Bob Mar 12 '12 at 15:12

6 Answers 6

Remember to add the string "nomodeset" to your /etc/default/grub, in GRUB_CMDLINE_LINUX_DEFAULT= line, or your nvidia driver won't work

PS: you have to run "sudo update-grub" after the modifications.... :)

share|improve this answer
    
It tells me that nomodeset not found... –  Dodgie Apr 10 at 17:34

Just a quick question: Why are you downloading the drivers from Nvidia directly? The packages available through jockey (the Additional Drivers application) should be fine for most people and if you don't fit into "most people", using the X-SWAT PPA should give you the latest version of the nvidia driver.

Anyway, what you want is simple. Firstly you have to get out of X before you can install. You can do that by switching to a virtual terminal (tty) by pressing ctrl+alt+ F1 logging on and then running sudo stop lightdm. Now run the installer. If it's still moaning about nouveau continue:

Run sudoedit /etc/modprobe.d/nvidia-graphics-drivers.conf and fill it with this:

# This file was installed by nvidia-current-updates
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current
blacklist nvidia-173-updates
blacklist nvidia-96-updates
alias nvidia nvidia_current_updates
alias nouveau off
alias lbm-nouveau off

The driver will create that file when it's installed, but you just want to speed things along. You'll need to reboot and kill X again now.

Then run the installer and all should be fine.

share|improve this answer
1  
I tried this out and it didn't do anything. I'm still getting the incompatibility error from the Nvidia install script. –  Jake Mar 23 '12 at 20:10
    
thanks Oli, you saved my day..!! –  alekhine Jul 31 '12 at 15:34
    
To anyone reading this I would strongly suggest that you use X-SWAT PPA as that should work and the blacklist solution might or might not (it didn't in my case). –  enedene Aug 21 '12 at 19:33
    
I just installed the NVIDIA 64 bit drivers (310) for my GeForce 210 and the installer did the disabling step for me. Rebooted and it installed fine. :) –  EM-Creations Feb 3 '13 at 11:00
    
@geezanansa It's in there already (second paragraph). LightDM controls X. –  Oli Apr 12 '13 at 13:05

All links above are correct, however you must run sudo update-initramfs -u so the initramfs can be purged of nouveau

share|improve this answer

I am just a little penguin and have found disabling/blacklisting nouveau breaks many features within ubuntu especially window management items(i.e. missing menus etc which is fine if you know keyboard shortcuts for navigation/operation.) NVidia themselves in the readme highlight the possible need to create another file if modeprobe.d/blacklist allready contains anythingelse. It is possible to change from mesa to vesa drivers by disabling nouveau in ubuntu. Using mesa or vesa will give different listings in jockey(additional drivers) as will using jockey-common(handy for adding older drivers to jockey list) There has been much hard work going on in this department by many and have found personally that the recommended driver has been hugely improved in recent months as well as the NVidia 310 driver being available either in ubuntu software centre or additional drivers after activating proposed updates in Software Sources (and then updating). What i have found after installation is that there is never a proprietary driver installed which means little things like launcher icon size can not be adjusted (system settings>appearance) which is indicative of a 2d session and not 3d session (newer flavours). So bearing in mind the ubuntu philosophy and the fact different people use their machines for different things; it might be worth asking,"Is it a bug? and/or What happens when nouveau is disabled?

share|improve this answer

Put the file nvidia-graphics-drivers.conf under the /etc/modprobe.d/ directory and then reboot the system.

Get into console and execute NVIDIA-Linux-x86-319.32.run again, thus it won't get the incompatibility error.

share|improve this answer

Can you add your graphics card model and Ubuntu version to the question?

Even though you can download 96 series drivers from nVidia's website, it will be incompatible with the latest version of Xorg and will not install.You can make an attempt to downgrade your X server, but you may find that other features of Ubuntu will be broken and you may even be unable to get to any sort of graphical desktop. I would provide instructions on how to do this, but I don't know which version of Ubuntu you're using. Maybe you can find out with a Google search. See post #7, here, or this launchpad project, which may be, well, fun to try ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.