Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know, this topic was here before.... but none of the suggestions helped and I'm confused, I don't know what I am missing. But lets begin.

I have a Ubuntu 11.10 which was upgraded by all those years from 8.04 so It's kind of old, but all works fine except theme.

Right after install all looked great but after one of updates (don't know which) theme got crappy. Let's start with lightdm. It looks fine, but settings button is not transparent (it has common GT border) and password entry box is not rounded. Instead of dots to mask password I see '*'. Well I think this is a small problem, the bigger one are the menus. Also context menus are the same, other menus looks ok.

After I login unity starts and looks.... well as it should look. But expanding any menu from notification area (including user switch and system menu) spoils that effect. I have a strange theme on those menus. Light gray background, darker gray text (almost unreadable) and black separators/inactive items. Selection looks normal (orange bg/white text)

There is also one more strange thing. Menus from nautilus are under title bar instead on unity panel (I have reinstalled appmenu-gtk3 appmenu-gtk appmenu-qt)

Any suggestions?

I can post screens, but I think I covered all in text.


I've tried reinstalling theme packages, after that changing theme with advanced configuration util. This didn't help so I've reinstalled unity and still nothing.

Reinstaling unity menus also did not help. Editing some flags in gconf editor provided some results, but.... rather for worse. My theme looks like on screens below (done with my phone.... login screen doesn't have prtscr handling, and when menu is open for some reason ptrscr also doesn't work)

http://imageshack.us/photo/my-images/33/imag0082a.jpg/

http://imageshack.us/photo/my-images/811/imag0081nm.jpg/

share|improve this question

closed as too localized by Jorge Castro, Thomas W., Mitch, jrg Sep 2 '12 at 20:16

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Definitely worth posting a screenshot. Also, check /var/log/kern.log and /var/log/messages for errors related to gnome-settings-daemon. And check that gnome-settings-daemon is actually running in the first place (should be - things would look a lot worse if it's not). –  Scaine Mar 12 '12 at 9:33
1  
Please also link to the things you've tried before. It's impossible for us to help you if you don't give us specifics. –  Jorge Castro Mar 12 '12 at 21:52
    
Any ideas what this is? This problem makes me not sleep at night (seriously). I had similar problem in Mint after update, buy I solved this by reinstating all themes... Here this didn't work. I tried to create new profile, but it looks the same. –  dr4cul4 Mar 19 '12 at 9:39
    
SO I guess I'm sucked with this problem for now. –  dr4cul4 Mar 23 '12 at 7:18

Browse other questions tagged or ask your own question.