Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.10 with kernel 3.3rc6. I tried to install Virtualbox 4.1.8 with the AMD64 .deb package off the virtualbox site. On install I got a kernel panic saying "unable to handle kernel paging request at ffff...".

When I reboot into Ubuntu now, just after it boots up, it starts to run unattended upgrades and I again get:

* Starting VirtualBox kernel modules
unable to handle kernel paging request at ffff...
...etc

I booted up okay on recovery mode, but when I shut down the system it gets stuck on:

* Stopping VirtualBox kernel modules

and I have to manually power down.

If I try sudo apt-get remove virtualbox-4.1, it similarly gets stuck while stopping the virtualbox kernel modules.

At the moment I'd be happy just removing the problematic install so my system boots up okay. I don't really need virtualbox right now, but I do need a working system. Thanks for the help!

share|improve this question

1 Answer 1

I managed to sort this out very crudely. I renamed /etc/init.d/vboxdrv to vboxdrv.bak so that the Virtualbox kernel module service would not start (and hence not get stuck while stopping.)

I then rebooted and did a sudo apt-get remove --purge virtualbox-4.1, which worked fine.

I'm sure there's a more elegant way to do this, and I'll be happy if someone suggests that, but I'm glad this worked for me as I urgently needed my PC up and running.

EDIT: The problem appeared to be due to the kernel upgrade - I tried 3.3rc6 with 11.10, and 3.3rc7 with 12.04 and both caused the problems I described with Virtualbox and VMWare.

However Virtualbox works just fine on stable kernel versions - I'm currently on 3.2.0-18 on Ubuntu 12.04 (I have not tried VMWare but I assume the problem with that will be solved too)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.