Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got my graphics card installed,msi radeon hd6450.My question is this card is supposed to have 2 gigs of ddr5 memory on it but after running a couple commands its only showing 256megs ?Is there something I can do to fix this or is this just a normal thing and the 256megs is a generic reading for all cards ?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If you are using ATI video card, and if you installed the proprietary drivers, you should have Catalyst Control center installed. There you can see in the Information menu the total memory size:

enter image description here

From command line, you can use the command:

lspci -v | grep VGA -A12

Output should be like:

01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4870] (prog-if 00 [VGA controller])
    Subsystem: PC Partner Limited Device 0502
    Flags: bus master, fast devsel, latency 0, IRQ 49
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at fe7e0000 (64-bit, non-prefetchable) [size=64K]
    I/O ports at a000 [size=256]
    Expansion ROM at fe7c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: fglrx_pci
    Kernel modules: fglrx, radeon

The following command will give you the amount of prefetchable memory:

$ lspci -v -s `lspci | awk '/VGA/{print $1}'` | sed -n '/Memory.*, prefetchable/s/.*\[size=\([^]]\+\)\]/\1/p'
$ 256M
share|improve this answer
    
yes I have catalyst installed and it says I have the 2 gigs,so im taking it the 256megs readings in the command prompt are not accurate?but as long as catalyst says I have the 2 gigs I m good.Thank you for your answer bioshark –  robert Mar 13 '12 at 23:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.