Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have foolishly deleted the libssl-1.0.0, I have completely deleted the src, lib and all the files that look like (*lib*ssl1*) or something like that!

I tried to use the synaptic package manager to update, or re-install the missing library, no luck, the returned error "E: Internal Error, No file name for libssl1.0.0" appears.

I tired to use apt-get --reinstall, download-only...same error

I included also all packages that have libssl* in their name, no good too.

today the system has been running silly, firefox and flash at chromium aren't working...

anyway I can recover without having to use live CD? thanks in advance!

share|improve this question
Please paste the exact errors into your question, thanks! – Jorge Castro Mar 12 '12 at 21:46

yes,whats yours Ubuntu version - Get those deleted files from similar running machines (if you are using 64-bit machine,make sure other machine also runs with 64-bit) and place it under lib or whatever files you have deleted.That should most likely work.

Sometime back - I deleted files from lib and etc , I was able to fix by copying files into that directory from another running system. It was trail & error trick , but it should work.

share|improve this answer
thank you for the effort @lakshmipathi I've decided to leave things as they are as after removing ff and re-installing flash my laptop seems to be stable – Manasrah Mar 16 '12 at 19:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.