Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to do a ntfsck to a NTFS partition I get this:

sudo ntfsck /dev/sdb1
Unsupported: replay_log()
Volume is dirty.
Unsupported: check_volume()
Checking 161792 MFT records.
Unsupported cases found.

How can I clean a "dirty" NTFS volume without having to actually use windows chkdsk tool in the NTFS volume.

I also did a ntfsfix and it said that everything was OK but it actually was not.

I also get the same "Dirty" error when trying to check the filesystem using the Disk Utility:

enter image description here

I am starting to think I need some powerful soap.

share|improve this question
    
I don't know if this will help, but I came across this bootable utility disk that has DOS and a miniXP that looks interesting: hirem's boot CD –  Marty Fried Mar 12 '12 at 0:07

2 Answers 2

up vote 11 down vote accepted

Try using ntfsfix, which is part of the ntfsprogs package (which you may already have installed). This is a command line utility which attempts to fix common NTFS problems. It's been a while since I last used it, but it should do its job simply by typing:

sudo ntfsfix /dev/sdb1

It also offers a specific option to clear the "dirty" flag on the partition:

sudo ntfsfix -d /dev/sdb1

which might or might not be required in addition to the first command. Have a look at man ntfsfix for more information.

share|improve this answer
    
I am very sorry. I also did test with that command before doing the ntfsck. I will add it to the question sorry. Also after doing a fix it did not mention anything wrong it just said that everything was ok. –  Luis Mar 11 '12 at 22:25
    
Even the '-d' option? Well, in that case I don't have much else to contribute, sorry about that.. –  pablomme Mar 11 '12 at 23:17
    
No, did not test the -d option. Will test tonight and let you know tomorrow if it worked. –  Luis Mar 12 '12 at 2:04
    
Actually ntfsck is the one with the -d parameter but anyway it does not solve the problem. It keeps on telling me that it is a dirty partition. Sounds sexy but is not. –  Luis Mar 23 '12 at 0:05
1  
ntfsck is deprecated and no longer distributed. The -d option has been integrated into ntfsfix instead. –  Mahmoud Al-Qudsi Oct 29 '12 at 0:50

I think it may actually be that you need to stop checking it. :)

I believe I once had similar reports, and I even booted into the original Windows install that made it to run chkdsk, which didn't help. But what I learned was that Linux couldn't check an NTFS partition, and it should be mounted with the fsckorder set to zero.

I'm not certain if this has changed since then, but hopefully you can crosscheck this to see if it might solve your problem.

Edit: Forgot to add, I've had no problems with this partition since that time.

share|improve this answer
    
I had the same "Not Clean" dialog on an external NTFS drive when connected to my Ubuntu machine. I ran chkdsk on that drive on a windows machine, and it found no problems with it. I guess that the dialog on Linux is unreliable. –  uval Mar 12 at 13:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.