Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do you maximize sound volume in Gnome Shell under Ubuntu 11.10?

I have a Macbook, and my sound and volume keys generally work, but even if I use the volume keys to set volume to 100%, the sound is very low. However, if I open the Sound dialog, the "Output Volume" slider goes up to 150%, which allows me to comfortably hear sound. Unfortunately, if I use the volume keys thereafter, it practically mutes the sound again, and doesn't let me increase the volume to 150% without first opening the Sound Settings dialog. I know how to use System Settings to increase volume beyond 100%. What I want is for 100% to actually be the true 100% so when I use the volume key to increase volume, it doesn't decrease volume. e.g. If I set it to 150%, and then press the "increase volume" key, the volume goes down to 100%.

I've found plenty of solutions for getting sound working in general, but nothing for this specific case where 100% volume does not actually represent full volume. I'm not sure how else to describe this, or what specifically I should be searching for to resolve it on my own.

share|improve this question

closed as off-topic by Braiam, Mateo, Thomas W., Avinash Raj, Glutanimate Dec 16 '13 at 7:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Mateo, Avinash Raj, Glutanimate
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have the same issue - I posted this bug here and used most of your description - bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/971878 –  Elijah Lynn Apr 2 '12 at 20:34
    
I posted an answer to a related question here. The trick is to use a small script that is activated if you use your volume buttons. askubuntu.com/a/301644/162833 –  C-Otto May 29 '13 at 18:17
    
Feature request/bug bugs.launchpad.net/hundredpapercuts/+bug/786725 –  Braiam Dec 16 '13 at 3:09
    
user posted bug report as answer: bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/971878 –  Mateo Dec 16 '13 at 4:00
add comment

2 Answers 2

I believe maximising your volume could be achieved in the following steps:

  1. Go to System Settings through the User Indicator on Top Far Right.

  2. Select Sound in System Settings

  3. At the top of the Sound Diaglog toggle your volume past the 100% mark to a setting that meets your needs.

I have attached the following screenshot to assist you: !System Settings/Soundhttp://i.imgur.com/Yoweg.png

share|improve this answer
    
This isn't the issue. I know how to use System Settings to increase volume beyond 100%. What I want is for 100% to actually be the true 100% so when I use the volume key to increase volume, it doesn't decrease volume. e.g. If I set it to 150%, and then press the "increase volume" key, the volume goes down to 100%. –  Cerin Mar 12 '12 at 7:30
add comment

I think the problem the OP is having is that even though he sets the audio to max, every time he uses the hardware volume keys it lowers the volume again.

One possible thing to check is whether it's the PCM or Master volume being altered. Install gnome-alsa-mixer to check.

Screenshot: http://dl.dropbox.com/u/1140666/screenshots-do-not-remove/Gnome-alsa-mixer-Screenshot%20at%202012-03-12%2004%3A23%3A40.png

share|improve this answer
    
Actually, it might be a bug related to your specific sound system. I had a similar issue in 11.10 with sound which was fixed in 12.04. I recommend you to report a bug. –  Hanynowsky Mar 12 '12 at 8:56
    
Unfortunately, alsa mixer shows everything at 100% regardless of whether or not Sound Settings shows volume at 100% or 150%. –  Cerin Mar 12 '12 at 15:06
    
My mic volume likes to increase even when I set it lower –  bkerensa Mar 17 '12 at 0:40
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.