Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I'm about to install a program in the terminal it wants the password:

[sudo] password for xxx:

But when I want to type my password it happens nothing. What should I do?

share|improve this question
    
Terminal doesn't echo you keyboard's input cause of security reasons, so you're not able to see any character. –  sparkmood Jul 4 at 9:58
add comment

7 Answers 7

Even though no characters appear when you type your password, you are actually typing your password.

So type password, then hit Enter and see the magic.

share|improve this answer
add comment

Passwords are hidden so no-one can see over your shoulder when you enter it. It's a security measure.

share|improve this answer
add comment

Password is not shown when you write it in the terminal after the sudo command but it is still read. Is this the case here? i.e. have you tried to give your password and press Enter?

share|improve this answer
add comment

Nothing is supposed to happen, just type the password and hit Enter.

share|improve this answer
add comment

For security reasons there is no feedback of passwords given in the terminal. Read the following discussion on reasoning behind this and why this will not be implemented:

In this discussion, and also given in the answer to a corresponding question at superuser

There is an option to enable password feedback for sudo and only for sudo by editing options in the sudoers file.

Warning: The instructions below are for advanced users only. If something goes wrong when editing the sudoers file, and this file is inaccessible or malformed you will have effectively locked out yourself and any other administrator users of performing any administrative tasks in your system. It is not a good idea to do this on a productive system.

To enable password feedback by asterisks * when running the sudo command we have to edit the sudoers file with

sudo visudo

We then will have to add pwfeedback to the default options as shown below:

Defaults        env_reset,pwfeedback
share|improve this answer
add comment

For security reasons, characters typed in at the password request prompt are not echoed back to the terminal. Type your password and hit enter. The characters are there, you just can't see them, that's all.

share|improve this answer
add comment

When using the terminal, for security reasons (Like if someone is standing just behind you and has nothing else to do but stare at your screen while you type a password) you will never see your typed password. You are effectively typing it even if you don't see it.

So just type your password and press ENTER

enter image description here

Here I am checking one of my drives. As you can see, it would look like I did not type my password but I indeed have.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.