Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I find a list of packages that are outdated and need to be upgraded using aptitude?

I am using Ubuntu 10.04.

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

update-manager (sitting in System -> Administration) should probably be your first port of call. Though if you want a command-line version:

sudo apt-get update
sudo apt-get dist-upgrade

aptitude and synaptic can also tell you.

share|improve this answer
    
Please change this to say "dist-upgrade". Just doing "upgrade" can end up skipping new kernels, new libraries, etc. It's almost never right to just use "upgrade". –  Kees Cook Nov 3 '10 at 17:22
2  
Fair point. As an explanation for others, upgrade will only upgrade installed packages. For things like kernels (installed as a dependency of the metapackage linux-image) each kernel version has its own package name (eg: linux-image-2.6.35.7). This is common in packages where having multiple versions available is desirable. apt-get upgrade would therefore not upgrade you to linux-image-2.6.35.8 if and when linux-image changed its dependencies because ....8 is a new package. dist-upgrade would. –  Oli Nov 3 '10 at 18:04
add comment

Another way to achive that from the command line is that of apt-show-versions.
The man page states:

apt-show-versions parses the dpkg status file and the APT lists for the installed and available package versions and distribution and shows upgrade options within the specific distribution of the selected package.

Once you've installed the package:

$ sudo apt-get install apt-show-versions

the only thing you have to do is:

$ sudo apt-show-versions -u

Hope that helps

share|improve this answer
add comment

Aptitude doesn't handle package installation as well as apt-get, so I would recommend sticking with apt-get. To get a list of packages that need to be installed, I would use the --dry-run option:

sudo apt-get dist-upgrade --dry-run | grep ^Inst | cut -d" " -f2
share|improve this answer
1  
What's wrong with aptitude? I use it for most of my package selections both on my desktop and on my servers. –  Oli Nov 3 '10 at 18:06
    
Nothing is strictly wrong with aptitude, but since the Update Manager and apt-get share a development history, it's usually easier to get support for problems with apt-get than aptitude. In the past, aptitude's conflict resolver has been much better, but the gap there has been closing. It's a matter of taste. :) –  Kees Cook Nov 3 '10 at 19:51
add comment

In synaptic: from left "Status" and select "installed (upgradable)", or just use update-manager which shows all needed updates.

Synaptic: System->Administrator->Synaptic Package manager

Update manager: System->Administrator->Update manager

share|improve this answer
    
"upgradeable (upstream)" is something entirely different... –  JanC Nov 3 '10 at 17:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.