Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to ubuntu and have installed version 11.10 alongside windows. I have got a mblaze MTS wireless usb which I use to connect to internet. I have installed its drivers which were provided by mblaze.

Now, when I connect through its software interface, everything works fine and I connect to internet. But the problem is that the network manager doesn't show me connected. As a result, I am not able to install softwares through software manager ( "install"/"use this source" button is disabled ). Then, I manually created the mobile broadband connection. even then, it doesn't connect.

I heard that synaptic can be used to install softwares too but it is not installed by default and I don't know how to install it from terminal. My problem will be solved if either:

  1. Network manager shows me connected when I connect through software interface
  2. I be able to connect manually
  3. Synaptic manager is installed through terminal. I know the command is sudo apt-get install synaptic but it doesn't work probably because sources.list hasn't got it. And I don't know the exact steps.

Edit : My hardware config :

2nd generation core i3 ( 2330 M) , 4 GB DDR3 RAM, 500 GB HDD, 1 GB AMD Radeon HD 6470M

'lsusb' gives the following :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0a5c:21e3 Broadcom Corp. 
Bus 002 Device 003: ID 046d:c52e Logitech, Inc. 
Bus 002 Device 004: ID 05c8:021e Cheng Uei Precision Industry Co., Ltd (Foxlink) 
Bus 001 Device 007: ID 19d2:fff1 ONDA Communication S.p.A. 

Additional info : Just installed the synaptic manager and I am able to install softwares through it. Though I would like to solve other problems too.

Just noticed this : When I didn't plug in my dongle, the option of connecting through mobile broadband doesn't show up. However, when I plug in the device, it shows the option of connecting mblaze modem (the manual connection I made). But as usual, it just tries to connect and doesn't succeed.

share|improve this question
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information? – Jorge Castro Mar 11 '12 at 17:36
Can you add the information for the modem? Synaptic won't be able to install the software either as you don't have an internet connection yet. – Jorge Castro Mar 11 '12 at 17:37
Thanks. Added the information. btw, I am able to connect to internet and sudo apt-get-update command also downloads the updates. Its just that the network manager doesn't show me connected. – dotnetguy Mar 12 '12 at 15:06
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. This is to help with the $Ask Ubuntu Clean Up. If you feel this question is not abandoned, please flag the question explaining that. :) – Seth Jan 1 '13 at 4:22

I am using wvdial,so same is the case with me,

You can still use the Software Center, even with the install button disabled. Instead of clicking in the button, move your mouse to the top of the screen so the menu is revealed and choose File->Install

If you want to install synaptic from the command line, in the Software Center, select the Edit menu and then click on software sources. Be sure than universe is selected. Then open the terminal and type

sudo apt-get update
sudo apt-get install synaptic
share|improve this answer
1. File->'Install' is disabled too. – dotnetguy Mar 12 '12 at 15:07
Synaptic manager is installed. Thanks. Just installed vlc media player. Although I would love to solve my other problems also. – dotnetguy Mar 12 '12 at 15:25
I it is better to file a bug report in launchpad :) – Tachyons Mar 12 '12 at 16:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.