Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I found this nice demonstration showing the use of SyncTeX with Gedit and evince. I would like to use this nice feature but my Ubuntu Natty Narwhal (11.04) does not have Gedit in the version of 2.32.

kon@pc:~$ gedit --version 
gedit - Version 2.30.4
kon@pc:~$ evince --version
GNOME Document Viewer 2.32.0

How do I update Gedit being able to use SyncTeX?

share|improve this question

2 Answers 2

The link you provided mentions that the SyncTex is a new feature of Gnome 2.32 and not Gedit 2.32.
You can check which gnome version you have by executing gnome-session --version.

To enable the SyncTex you will have to install the gedit extra plugins by executing sudo apt-get install gedit-plugins. After installation open Gedit and enable the plugin from the Edit -> Preferences -> Plugins menu.

share|improve this answer
    
Hey @yossile, if I execute the the command, it produces the message "Unknown option --version". But my Gnome says that I have version 2.32.1 installed (System -> About Gnome). –  kon Mar 11 '12 at 13:37
    
@kon please see my corrected answer –  yossile Mar 11 '12 at 13:46
    
I installed gedit-plugins but the plugin tab does not show synctex plugin. The version of the installed package gedit-plugins is 2.30. I had a look at the version of 2.32 and the synctex plugin is there. –  kon Mar 11 '12 at 14:27
up vote 0 down vote accepted

I wasn't able to solve this problem. Now I'm using TexMaker(v 2.2.1), it has the sync feature already build in. Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.