Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am trying to install OpenCV on Ubuntu 10.10 to use it with python.

The problem that I am facing is related to installing gtk2.0-dev.

I always get the following error

The following packages have unmet dependencies:
libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.25.8) but it is not going to be installed
         Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
         Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
         Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
         Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed

I tried to do everything what I found on the web to overcome the problem. I even tried to use Synaptic Manager where I found libgtk2.0-dev, but it gives me an error on the dependencies too.

Thanks in advance.

share|improve this question

marked as duplicate by hhlp, Seth, con-f-use, Eric Carvalho, Eliah Kagan Mar 18 '13 at 2:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

This seems to work fine for me in a chroot. You'll want to make sure your apt sources are up to date.

sudo apt-get update

or alternatively, just use synaptic to update them.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.