Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have Dolby Virtual Surround Sound 5.1 speakers with Tuba CineBass Subwoofer on Acer laptop (mine is 5951G but there is also bunch of models with similar configuration of speakers with/without subwoofer). In Windows it works and sounds amazingly after installing both Realtek drivers and Dolby software from Acer support site. In Ubuntu only 2-channel sound is working.

How can I enable virtual 5.1 sound or at least subwoofer?

share|improve this question

3 Answers 3

use alsamixer but first, install the extra driver support:

sudo apt-get install alsa-firmware-loaders alsa-tools alsa-tools-gui

At this point, you may need to reboot.

Then, execute the following commands in an open terminal:


Then, press F6 use the arrow key to select your sound card and then press ENTER.

Next, press F5 and scroll to the right using the arrow keys until you get to Auto-Mute. Use the up arrow key to disable automute.

Finally, scroll to the subwoofer using the left or right arrow key and control the volume using the up and down arrow keys. Also, press the M key to mute or unmute each channel.

share|improve this answer
I've followed your answer, but sound wasn't affected by disabling "Auto-Mute" and there is no "Subwoofer" column. Also alsa-firmware package isn't available from repositories and installing package compiled from source returns error: trying to overwrite '/lib/firmware/yamaha/ds1e_ctrl.fw', which is also in package linux-firmware 1.143.1 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) – janot Jul 20 at 20:10
@janot I got that from one of the wiki pages which are sometimes out of date. The alsa-firmware package is probably not available because the firmware is most likely included in linux-firmware now so just install the rest of the packages listed. Do you have more than one sound card listed? – mchid Jul 21 at 2:35
alsamixer shows only HDA Intel PCH – janot Jul 21 at 6:07

According to the link in the other answer, you may have to edit the following file to enable 5.1 audio. Run the following command:

sudo nano /etc/pulse/daemon.conf

Then, press CTRL + W, type:

channels = 2

and then press ENTER to take you to the line you need to edit.

Now, change the 2 to 6 and remove the ; character and the following space at the beginning of the line so that the line should look like this:

default-sample-channels = 6

Finally, press CTRL + o and then press ENTER to save the file. Press CTRL + x to exit and then reboot.

share|improve this answer
That also has not effect – janot Jul 21 at 6:09
@janot check out the answer from "Unknown-Master" on this thread as they seem to have got it working – mchid Jul 22 at 21:00
Tried this without any result with all available pins. But then I've partially disassembled subwoofer and found that it's actually kind of working when right speaker is used. It's membrane trembles at least.. Looks like it was working all the time this way. Maybe you have and idea what's going on and how to get it working with both speakers, somehow separate it from right speaker... – janot Jul 24 at 11:30

A quick google search found this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.