Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to enable XDMCP on GDM without much success. Following some instructions I have edited /etc/gdm/custom.conf and added:

[daemon]
RemoteGreeter=/usr/lib/gdm/gdm-xdmcp-chooser-slave
[xdmcp]
Enable=true

Then restarted gdm and tried to connect both locally and from a remote system with:

Xnest :1 -query localhost
Xnest :1 -query remote_system_hostname

I just get a black screen instead of the GDM window as expected. I am missing something ?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Wait for this bug to be fixed: https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/669670

share|improve this answer
    
Oh another regression :( –  João Pinto Nov 4 '10 at 8:30

For LightDM which is in the latest Unity based Ubuntus I used this answer: XDMCP setup for lightdm, ports not listening

And you will probably need to also add the SeatDefaults setting in the answer i.e.

[SeatDefaults]
xserver-allow-tcp=true

And you may also need to enable access to your local server by using

xhost +<remote hostname> 

or just

xhost + 

to disable it completely

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.