Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I made the mistake of trying out some settings through Administration -> Language Support. Now my user account has LANG set to fi_FI.utf8, even though I want to use en_US.utf8. (This is kind-of a follow up to this.)

Listing 1: current locale settings for my user account:

$ locale
LANG=fi_FI.utf8
LANGUAGE=en
LC_CTYPE="fi_FI.utf8"
LC_NUMERIC="fi_FI.utf8"
LC_TIME=en_GB.UTF-8
LC_COLLATE="fi_FI.utf8"
LC_MONETARY="fi_FI.utf8"
LC_MESSAGES="fi_FI.utf8"
LC_PAPER=fi_FI.utf8
LC_NAME="fi_FI.utf8"
LC_ADDRESS="fi_FI.utf8"
LC_TELEPHONE="fi_FI.utf8"
LC_MEASUREMENT=fi_FI.utf8
LC_IDENTIFICATION="fi_FI.utf8"
LC_ALL=

Listing 2: /etc/default/locale which contains the locale settings I want to use:

$ cat /etc/default/locale 
LANG="en_US.utf8"

LC_TIME="en_GB.UTF-8"
LC_PAPER="fi_FI.utf8"
LC_MEASUREMENT="fi_FI.utf8"

The Administration -> Language support settings look like this:

My specific questions:

  • Where exactly (in what file) are the user-specific locale settings (listing 1) stored?
  • What is the recommended way of changing that? By editing a file or through some config UI? (I want to use the settings in listing 2.)

The root annoyance which prompted me to ask this: How to change Firefox UI language from Finnish back to English?

I'm using Ubuntu 10.04 if that makes any difference.

share|improve this question

marked as duplicate by Tachyons, Basharat Sialvi, dobey, Thomas W., Uri Herrera Apr 19 '13 at 20:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
If you want to start a single program in english you can always run it with ALT+F2 (or terminal) using this: $ LANG=POSIX firefox –  mniess Nov 3 '10 at 15:09
add comment

4 Answers 4

up vote 7 down vote accepted

Specify the language at the login prompt after selecting the user. When asked whether to make the selection the new default, select yes.

share|improve this answer
    
+1, that worked, thanks. (It didn't ask anything about setting default but the selection did seem to persist.) I'm still interested in more details though: whether user's locale can be configured in a file etc. –  Jonik Nov 3 '10 at 15:30
2  
The system-locale is stored in /etc/default/locale. Userspecific locale settings are supposed to go in ~/.profile by adding something like LANG=en_EN.utf8. –  mniess Nov 3 '10 at 16:19
add comment

The per-user locale default for the Desktop session is stored in ~/.dmrc. This is the file that is updated when selecting a new locale at the GDM screen. GDM uses this to set up the environment when starting the user's session.

share|improve this answer
    
Thanks. So apparently the GDM selection sets LANG and also fills in any of LC_* with selected locale, except those set in /etc/default/locale. Fair enough. –  Jonik Nov 4 '10 at 7:49
add comment

Just open terminal and type sudo gedit then the text editor will open.
Then open the file locale located underneath the etc/default.
Then just edit the LANGUAGE=en and LANG="en_US.utf8".

share|improve this answer
add comment

If "User Accounts" is crashing each time you start it, you should reset the accounts.

To get the error-message, run 'gnome-control-center' from a terminal and click on "User Accounts". You'll probably see something like this:

    (gnome-control-center:5060): common-cc-panel-WARNING **: locale 'xx_XX:nl_NL:en_GB:en
    xx_XX' isn't valid

To fix, run the command gnome-language-selector. Try changing the locale and language settings to a different one and see if that resolves your problem. Then change back.

Also run sudo dpkg-reconfigure locales to see of there are any cache-errors. By purging the bad locales with sudo dpkg-reconfigure localepurge you could probably solve the original problem which caused the crashing.

[source]

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.