Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
error! bad return status for module build on kernel: 2.6.32-39-generic (i686)
consult the make. log in the build directory 
/var/lib/dkms/keucr//0.0.1/build/for more information.
dpkg:error processing keur-dkms (--configure):
subprocess installed post-installation script returned error exit status 10
setting up libabbal-0.0-0 (0.0.22-1build1) ...

Also when I click on gimp, a loading symbol comes up but nothing happens.

share|improve this question
add comment

2 Answers 2

Try updating from the terminal instead of a package manager. You will see the dependencies that are causing it to fail to load. For example, the following packages are Gimp dependencies:

Depends: libglib2.0-0
Depends: libgtk2.0-0
Depends: libjpeg62
Depends: librsvg2-2
Depends: zlib1g
Depends: python

If you notice it's hanging on libglib2.0-0, then try sudo apt-get install llbglib2.0-0. If it installs, try sudo apt-get install gimp and note the failed dependencies and repeat the previous step replacing it with the new failed dep.

Hopefully someone knows a better way, but this is how I resolve some issues if using: sudo apt-get install gimp --fix-missing, or sudo apt-get -f install gimp doesn't work. Some of the dependencies will have their own dependencies that may cause them to fail as well. Just trace them down until you can install all dep's.

share|improve this answer
    
Hi thanks for that. But cant get it to work I had the libabbal-0.0 error message originally when try to fix it so im not sure if its the orgiginal fault. I tried typing in all the command lines you have written but its still coming up with the error message. im unfamiliar with the depends: commands I tried typing those in as well but they are not recognised –  harpy04 Mar 10 '12 at 19:19
    
Those weren't for copy and pasting, just an example. If you try to install gimp from the terminal you will see some Error code that will say "Depends: zlib1g ..." for example. You would then need to try to do sudo apt-get install zlib1g. THAT IS ONLY AN EXAMPLE. You'll need to use the actual packages that are failing to install that gimp depends on. If you past-bin your error code and link to it, I'll try to be move specific. –  Jeremy Jared Mar 10 '12 at 19:26
add comment

Are you using GIMP from ppa:matthaeus123/mrw-gimp-svn (the latest gimp)? If you are, there was an update from 2.6->2.7 and 2.7 doesnt work with the current version of glib in oneiric. You must also add these repos:

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main
deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
share|improve this answer
    
sub-process /usr/bin/dpkg returned an error code (1) not sure if that help. went to website and tried installing latest version and as i was reading the code it said i had the latest version installed (I think). I only installed gimp a few months ago, unless there has been a recent update? –  harpy04 Mar 10 '12 at 21:51
    
also my cursor has now stopped working. so essentially the touchpad isnt working at the moment. Im busy looking for things to attempt to reinstall it but so far no luck –  harpy04 Mar 10 '12 at 22:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.