Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Thinkpad edge 520, installing drivers isn't possible because the site doesn't support Linux... My multitouch was working on a previous version of Ubuntu. On top of that i have a problem with my keyboard (maybe also driver problem?) I can't press keys fast after each other (or the same key, which is quite annoying). Anybody have any suggestions?

xinput list:
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=10   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=12   [slave  keyboard (3)]
share|improve this question
up vote 1 down vote accepted
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Two-Finger Scrolling" 8 1
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 8 1 1
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 32 10
xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 32 8

The above work for me. It is not persistent accross reboots, so I set up a script to enable multi touch every time Ubuntu boots

share|improve this answer
thanks, it works. Can you please also tell me how to make a script run at startup every time? – Petr Mar 10 '12 at 21:41

Please show us you output for xinput list.

Otherwise did you try this:

share|improve this answer
comment on end of the page: I have the same problem. I can use vertical edge scrolling but not horizontal edge scrolling on my touchpad. The Ubuntu Forum points to your comment on this page for a debian package that'll fix this bug. It explicitly points to your comments #115 and #116. You mention the debian package is attached but there's nothign there and comment #116 is missing (which I'm guessing had the attached files to install). Can you help me out and repots the bug fixer or can you direct me to where I can get this bug fixed? Thanks. – Petr Mar 10 '12 at 17:25
Try The Messie's solution, it should do the job. If not do xinput list-props 10 and look for Two-Finger Scrolling. – d_inevitable Mar 10 '12 at 20:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.