Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a Thinkpad T61p with Quadro FX570M. I just installed the Ubuntu 11.10. I have tried to download the driver LINUX DISPLAY DRIVER - X86 version 295.20 from NVIDIA, but I do not manage to install it. If I open System > Screens, there is an unknovn screen driver.

My installation works fine except, fails on resume with a black and white pattern all over the screen and I have difficulties detecting an external monitor.

Please, if you have any clue - help me out.

share|improve this question

marked as duplicate by Jorge Castro, Kevin Bowen, Basharat Sialvi, bcbc, Eric Carvalho Apr 25 '13 at 0:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

3 Answers 3

You can install the latest drivers for NVidia doing this:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-current nvidia-settings

if anything goes wrong, simply purge the ppa:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
share|improve this answer
add comment

launch jockey-gtk by pressing alt+f2 and then typing in jockey-gtk. It will list the drivers that apply for your hardware. Activate the Nvidia ones.

Otherwise, to install it from the Nvidia download, you would need to exit X-Server and run it there, which is more complicated and shouldn't be necessary. If you install it from jockey it will also be easier to keep the drivers up to date.

share|improve this answer
    
Thank you for your fast reply, my file ( NVIDIA-Linux-x86-295.20.run ) is in the downloads folder - what is the command I must use? Sorry, but I'm totally new to Linux and Ubuntu. –  Hurumhei Mar 10 '12 at 17:46
1  
Usually you should not download the driver like that, but instead install it with jockey-gtk. Only if it is not available there you should install it manually. –  d_inevitable Mar 10 '12 at 18:36
    
@ whoever downvoted my answer, would please revise your down-vote or at least have the decency to give a reason for it? –  d_inevitable Mar 10 '12 at 18:59
    
Thanks, using jockey-gtk I discover that the NVIDIA accelerated graphics driver version 173 is activated while NVIDIA has the above driver set for my hardware. What should I do - use the driver recommended by NVIDIA - use the current driver or the Ubuntu driver. I see many struggling with their NVIDIA drivers. –  Hurumhei Mar 11 '12 at 7:36
    
This means that you already have the NVIDIA drivers installed! To change display settings you need to use nvidia-settings and not the other tool. Unfortunately it is not that uncommon for new hardware to fail on resume in Linux. Yes it is a driver problem, but I don't think your downloaded driver will be any different. –  d_inevitable Mar 11 '12 at 14:32
show 2 more comments

I had similar issue with my ThinkPad t510 that had Intel display driver and Nvidia GT218 [NVS 3100M} driver. This is how I was able to switch default display driver to NVIDIA.

First clean-up any third-party NVIDIA drivers (in case you have them)

sudo apt-get purge xserver-xorg-video-nouveau

Then perform the following steps (as listed above by Messie, except the last line which includes --reinstall to cleanup the existing installation)

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get --reinstall install nvidia-current nvidia-settings

Reboot laptop and hold F-1 to get to the BIOS setup (thinkpad BIOS Setup).

go to Display
switch "Graphics Device" from "NVIDIA Optimus" to "Discrete Graphics"
change "OS Detection for NVIDIA Optimus" to "Disabled"
Save using F10 and let the boot continue

Now your laptop should be using NVIDIA as you can confirm by

nvidia-settings

To revert just reverse the listed steps.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.